Bug 1090203 - Evo hangs one whole workspace when a particular e-mail is selected in preview (ews?)
Summary: Evo hangs one whole workspace when a particular e-mail is selected in preview...
Keywords:
Status: CLOSED DUPLICATE of bug 1089966
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 20
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-22 22:40 UTC by Bojan Smojver
Modified: 2014-04-23 16:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-23 16:30:43 UTC


Attachments (Terms of Use)

Description Bojan Smojver 2014-04-22 22:40:21 UTC
Description of problem:
When I move to a particular e-mail (hosted on Exchange 2010, accessed via ews), the whole Gnome workspace, including Evo, becomes "frozen". Clicking on any other window will not work. I can still change the workspace (using workspace indicator extension) and do anything in any other workspace, but this one is frozen until I shut Evo down. Sometimes, it untangles itself after many minutes. Sometimes not.

The e-mail, which I cannot share here (unfortunately), has a single 81 kB attachement - a CSV file. It can be seen easily in Outlook.

Top does not really show any activity. Evo is not busy or anything, so looks like some sort of deadlock.

Version-Release number of selected component (if applicable):
evolution-3.10.4-2.fc20.i686

How reproducible:
Always.

Steps to Reproduce:
1. Click on the e-mail in question.
2. No preview.
3. Workspace freezes.

Actual results:
Whole workspace frozen.

Expected results:
Should not freeze.

Additional info:
Started some weeks ago?

Comment 1 Bojan Smojver 2014-04-22 22:43:07 UTC
One more thing. The "frozen workspace" behaviour is not the only way this bug manifests itself. Sometimes, it is just Evo that hangs. It displays "retrieving message <id>" down in the status bar and hangs. Clicking anywhere else in Evo does nothing.

Comment 2 Bojan Smojver 2014-04-22 23:02:52 UTC
This must be some kind of message display problem. I just turned preview off, positioned myself on the message and displayed source of it just fine (Ctrl + U). However, a double click on it (view), immediately hangs the interface.

Comment 3 Milan Crha 2014-04-23 07:04:05 UTC
Thanks for a bug report. I suppose the message's preview also causes high CPU usage. It would be good to install debuginfo packages for evolution-data-server and evolution, and get a backtrace of "running" evolution, like with:
   $ gdb --batch --ex "t a a bt" -pid=`pidof evolution` &>bt.txt
It (the bt.txt file) can contain some private information, thus make sure you'll not expose any (I usually search for "pass" at least (quotes for clarity only)). I suspect that webkit got stock in accessibility/a11y code, I recall some upstream bugs related to it.

Comment 4 Bojan Smojver 2014-04-23 07:43:18 UTC
(In reply to Milan Crha from comment #3)
> I suppose the message's preview also causes high
> CPU usage.

When any of the hangs happen, CPU usage is practically non-existent.

Comment 5 Bojan Smojver 2014-04-23 08:07:14 UTC
Backtraces sent privately.

Comment 6 Milan Crha 2014-04-23 16:30:43 UTC
Thanks, the backtraces helped to identify the issue. It is the same as bug #1089966, see the bug #1089966 comment #2 for a workaround.

*** This bug has been marked as a duplicate of bug 1089966 ***


Note You need to log in before you can comment on or make changes to this bug.