Bug 109022 - It is no longer possible to add an existing content type to a section
It is no longer possible to add an existing content type to a section
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: content types (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: 106597
  Show dependency treegraph
 
Reported: 2003-11-04 09:41 EST by Randy Graebner
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 11:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Graebner 2003-11-04 09:41:31 EST
Description of problem:
When I go to the content-types tab and remove a content type, I expect
to be able to click on the "add a content type" link, select the type,
and then add it back to my section.  However, whenever I hit the "add"
button it actually cancells.  This is from the form have a
CancelListener that fires and the CancelListener forgets to check if
the cancel button was actually pressed.  The below patch will fix this
problem.

[randyg@graebner aplaws]$ diff -uw
cms/src/com/arsdigita/cms/ui/type/ContentTypeAdminPane.java
cms/src/com/arsdigita/cms/ui/type/ContentTypeAdminPane2.java
--- cms/src/com/arsdigita/cms/ui/type/ContentTypeAdminPane.java	Tue
Nov  4 09:40:10 2003
+++ cms/src/com/arsdigita/cms/ui/type/ContentTypeAdminPane2.java	Tue
Nov  4 09:39:58 2003
@@ -150,10 +150,12 @@
         public void submitted(FormSectionEvent event) 
             throws FormProcessException {
             PageState state = event.getPageState();
+            if (m_form.isCancelled(state)) {
             getBody().pop(state);
             throw new FormProcessException("cancelled");
         }
     }
+    }
 
     private void resetPane(PageState state) {
         getBody().reset(state);


Version-Release number of selected component (if applicable):
Nightly

How reproducible:
Always

Steps to Reproduce:
1.  try to add a content type
2.
3.
  
Actual results:
the content type should be added

Expected results:
The content type remains unmapped.

Additional info:
Comment 1 Randy Graebner 2003-11-04 10:17:37 EST
This should be fixed in change 37666.
Comment 2 Scott Seago 2003-11-04 17:43:22 EST
This works for me now.

Note You need to log in before you can comment on or make changes to this bug.