Bug 109024 - gawk not issuing warnings
Summary: gawk not issuing warnings
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gawk   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-04 15:12 UTC by Stepan Kasal
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-09 14:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stepan Kasal 2003-11-04 15:12:29 UTC
What lead you to have gawk-3.1.0-shutup.patch?
I beleive these warnings are useful and often indicate that gawk is doing something else then what the programmer has intended.
They are issued only in cases which are described as
``giving undefined results'' in POSIX.

Comment 1 Florian La Roche 2003-11-04 23:37:23 UTC
This should probably honor some POSIXLY_CORRECT environment variable or
another option to enable warnings again instead of unconditionally
disabling this warning. I want to keep the default to not give a warning.

Florian La Roche


Comment 2 Stepan Kasal 2003-11-05 13:05:37 UTC
I don't care too much about the POSIXLY_CORRECT case.
I think it's useful in the default case.
It can help to discover a typo, like this:
$ gawk 'BEGIN{file="C:\win";print"\space"}'
gawk: cmd. line:1: warning: escape sequence `\w' treated as plain `w'
gawk: cmd. line:1: warning: escape sequence `\s' treated as plain `s'
space

Comment 3 Florian La Roche 2003-12-09 14:00:50 UTC
Ok, enabled warnings again. Will shut them off again if too many
complains and too old code is still showing up.

greetings,

Florian La Roche


Comment 4 Stepan Kasal 2003-12-16 11:56:03 UTC
Thank you very much.
Stepan Kasal


Note You need to log in before you can comment on or make changes to this bug.