Bug 109036 - Pxelinux default config file appended to not replaced
Summary: Pxelinux default config file appended to not replaced
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-04 16:36 UTC by Phillip Sorensen
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 13:14:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phillip Sorensen 2003-11-04 16:36:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Anytime I change a value that causes the
/tftpboot/linux-install/pxelinux.cfg/default to be rewritten, a new
copy is appended to the old one.  The new copy should replace the old
copy.

It appears to me, that the problem is in the pxeOSList.saveOSList
method in pxeos.py.  The line 

defaultFD=open("%s/pxelinux.cfg/default" % PXEBOOTDIR, "a")

should be

defaultFD=open("%s/pxelinux.cfg/default" % PXEBOOTDIR, "w")
                                                       -^-


Version-Release number of selected component (if applicable):
redhat-config-netboot-0.1.1-19

How reproducible:
Always

Steps to Reproduce:
1. Select Configure -> Network Installation from the menu of the
redhat-config-netboot window.
2. Click the close button
3. Check the /tftboot/linux-install/pxelinux.cfg/default file
4. Repeat


Additional info:

Comment 1 Daniel Walsh 2003-11-05 13:14:29 UTC
Thanks this bug is already fixed in rawhide  0.1.1-21

Dan



Note You need to log in before you can comment on or make changes to this bug.