Bug 1090596 - Seam 2.2 Drools doesn't work in EAP 6.3 on JDK8
Summary: Seam 2.2 Drools doesn't work in EAP 6.3 on JDK8
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Seam2
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Marek Novotny
QA Contact: Marek Schmidt
Russell Dickenson
URL:
Whiteboard:
Depends On: 1091383
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-23 17:11 UTC by Ron Šmeral
Modified: 2017-02-20 20:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-20 20:07:50 UTC
Type: Bug


Attachments (Terms of Use)
Reproducer (13.07 MB, application/zip)
2014-04-23 17:11 UTC, Ron Šmeral
no flags Details
server.log (16.11 KB, text/plain)
2014-04-23 17:12 UTC, Ron Šmeral
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker DROOLS-329 None None None Never
Red Hat One Jira Issue Tracker JBPAPP-11145 Major Resolved Seam 2.2 Drools doesn't work with Java 8 2017-11-09 21:27:04 UTC

Description Ron Šmeral 2014-04-23 17:11:11 UTC
Created attachment 889034 [details]
Reproducer

Description of problem:
The Seam 2.2 Drools module fails in EAP 6.3 on JDK8 with the following exception:
...
Caused by: java.lang.RuntimeException: wrong class format
	at org.drools.commons.jci.compilers.EclipseJavaCompiler$2.findType(EclipseJavaCompiler.java:260) [drools-compiler.jar:5.1.0.BRMS-jdk7]
	at org.drools.commons.jci.compilers.EclipseJavaCompiler$2.findType(EclipseJavaCompiler.java:204) [drools-compiler.jar:5.1.0.BRMS-jdk7]
...
Caused by: org.eclipse.jdt.internal.compiler.classfmt.ClassFormatException
	at org.eclipse.jdt.internal.compiler.classfmt.ClassFileReader.<init>(ClassFileReader.java:372) [ecj-4.3.1.redhat-1.jar:4.3.1.redhat-1]
	at org.drools.commons.jci.compilers.EclipseJavaCompiler$2.findType(EclipseJavaCompiler.java:254) [drools-compiler.jar:5.1.0.BRMS-jdk7]

Version-Release number of selected component (if applicable):
EAP 6.3.0.ER2 (target)
EAP 5.3.0.ER3 (Seam)

Steps to reproduce:
1. Deploy the EAP6-migrated Seam 2.2 Drools example to EAP 6.3 running on JDK8.
2. Open http://localhost:8080/seam-drools
3. Submit any valid number

Actual results:
HTTP 500 Error appears, with the above mentioned exception.

Expected results:
The application works.

Comment 1 Ron Šmeral 2014-04-23 17:12:55 UTC
Created attachment 889035 [details]
server.log

Comment 2 JBoss JIRA Server 2014-07-08 12:39:49 UTC
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-11145 to Resolved

Comment 4 Brad Maxwell 2017-02-20 20:07:50 UTC
Closing out old issues, this does not look like EAP issue as there is a drools bug, if there is an issue with JBoss, please open an upstream jira 
https://issues.jboss.org/browse/DROOLS-329


Note You need to log in before you can comment on or make changes to this bug.