Bug 1090645 - [Gnome 3.12] Tracker fails to start: "Could not create proxy on the D-Bus session bus, Error calling StartServiceByName"
Summary: [Gnome 3.12] Tracker fails to start: "Could not create proxy on the D-Bus ses...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: tracker   
(Show other bugs)
Version: 20
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-23 20:37 UTC by Greg K Nicholson
Modified: 2014-04-30 18:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 18:00:57 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg K Nicholson 2014-04-23 20:37:43 UTC
Description of problem:
Tracker fails to start when invoked with `tracker-control -s`.

Version-Release number of selected component (if applicable):
tracker-1.0.0-1.fc20.i686 from repo rhughes-f20-gnome-3-12

How reproducible:
Every time for me.

Steps to Reproduce:
1. Open Gnome Terminal
2. Run `tracker-control -s`

Actual results:

$ tracker-control -s
Starting miners…

(tracker-control:6346): Tracker-CRITICAL **: Could not create proxy on the D-Bus session bus, Error calling StartServiceByName for org.freedesktop.Tracker1.Miner.Files: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/libexec/tracker-miner-fs received signal 6

(tracker-control:6346): Tracker-CRITICAL **: Could not create proxy on the D-Bus session bus, Error calling StartServiceByName for org.freedesktop.Tracker1.Miner.Extract: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/libexec/tracker-extract exited with status 1

(tracker-control:6346): Tracker-CRITICAL **: Could not create proxy on the D-Bus session bus, Error calling StartServiceByName for org.freedesktop.Tracker1.Miner.Applications: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/libexec/tracker-miner-fs received signal 6

(tracker-control:6346): Tracker-CRITICAL **: No D-Bus proxy found for miner 'org.freedesktop.Tracker1.Miner.Files'
  ✗ File System (perhaps a disabled plugin?)

(tracker-control:6346): Tracker-CRITICAL **: No D-Bus proxy found for miner 'org.freedesktop.Tracker1.Miner.Extract'
  ✗ Extractor (perhaps a disabled plugin?)

(tracker-control:6346): Tracker-CRITICAL **: No D-Bus proxy found for miner 'org.freedesktop.Tracker1.Miner.Applications'
  ✗ Applications (perhaps a disabled plugin?)


Expected results:

Tracker starts. Gnome Documents shows documents. `tracker-control` shows that miners are running.


Additional info:

I've had the same problem for a long time — as far as I remember, Gnome Documents has never shown any documents — so I don't think this is caused by the Gnome 3.12 Copr repo.

My home folder has 7 years of cruft and it's quite possible that I've messed something up myself. If so, the error message doesn't say what I've done or how I can fix it, in a way that I can understand.

I'd appreciate any suggestions, or anything else I can try to help diagnose the problem.

Comment 1 Greg K Nicholson 2014-04-30 18:00:57 UTC
I seem to have fixed this. I found tracker's data in my home folder by running:

$ locate "\/home/*tracker*"

I deleted the relevant folders this command found:

$ rm -rf ~/.cache/tracker
$ rm -rf ~/.config/tracker/
$ rm -rf ~/.local/share/tracker/

Then I hard-reset tracker's database, and started tracker:

$ tracker-control -r
$ tracker-control -s


Note You need to log in before you can comment on or make changes to this bug.