Bug 1090671 - Content Management fails if default organization is deleted
Summary: Content Management fails if default organization is deleted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1100311
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-23 22:25 UTC by thunt
Modified: 2019-09-26 18:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Users of the Red Hat Satellite 6 Beta should not delete the org which is created during installation.
Clone Of:
Environment:
Last Closed: 2014-09-11 12:23:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6179 None None None 2016-04-22 16:55:00 UTC

Description thunt 2014-04-23 22:25:17 UTC
Description of problem:
Subscription management stops working if default organization is deleted.


Version-Release number of selected component (if applicable):
Satellite 6 beta as of 23-Apr-2014

How reproducible:
Happened twice

Steps to Reproduce:
- Install Satellite 6 beta.
- Go to "Manage Organizations"
- Create new organization - Example "My Demo Corp".
- Delete "ACME Corporation"
- Go to Content->Red Hat Subscriptions

Actual results:
Spinning Wheel and Loading Content - stays forever

Expected results:
Subscription Manifest page should be displayed.

Additional info:
Sorry, I didn't keep log files but there was a line about "organization_id" followed by Ruby stack trace if /var/log/foreman/production.log

Comment 1 RHEL Product and Program Management 2014-04-23 22:54:41 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 David Davis 2014-06-10 15:34:10 UTC
Org destroy has been pushed out to 6.0.4.

https://bugzilla.redhat.com/show_bug.cgi?id=1106563

Comment 4 thunt 2014-06-23 18:50:31 UTC
Could we also change the name of the default organization to something a little less cartoonish - Thanks

Comment 5 David Davis 2014-07-11 19:07:06 UTC
Confirmed as working as part of https://bugzilla.redhat.com/show_bug.cgi?id=1100311. QA, please verify.

Comment 8 Tazim Kolhar 2014-08-11 08:24:22 UTC
VERIFIED

Comment 9 Bryan Kearney 2014-09-11 12:23:54 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.