Bug 109079 - blas/lapack packages require a dependency on libf2c package
Summary: blas/lapack packages require a dependency on libf2c package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: lapack (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-04 22:10 UTC by Satish Balay
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 17:04:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Satish Balay 2003-11-04 22:10:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031016 Epiphany/1.0.4

Description of problem:
blas,lapack are compiled with g77 - and hence have a dependency on
-lg2c - which is part of libf2c package

Version-Release number of selected component (if applicable):
blas-3.0-22, lapack-3.0-22

How reproducible:
Always

Steps to Reproduce:
1. install blas (for eg: yum install blas)
2.
3.
    

Actual Results:   /usr/lib/libg2c.so.0 is not installed (because there
is no depencency from blas to libf2c

Expected Results:  the following packages should be installed 
libf2c
blas

Additional info:

Could you add in the pacakge depencency between 'blas' and 'libf2c' 
because - this depencency is real - and without -lf2c -lblas is not
useable

Also, additionally - a build dependency can be added for gcc-g77 - as
without this package (i.e without g77)  lapack.src.rpm cannot be compiled

Comment 1 Jeff Johnson 2004-01-05 17:04:53 UTC
Fixed in lapack-3.0-23.


Note You need to log in before you can comment on or make changes to this bug.