Bug 1091069 - Use system qtsingleapplication instead of bundled one
Use system qtsingleapplication instead of bundled one
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texmaker (Show other bugs)
rawhide
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-04-24 15:01 EDT by Ville Skyttä
Modified: 2014-12-06 23:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-06 23:02:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Use system qtsingleapplication instead of bundled one (3.94 KB, patch)
2014-04-24 15:01 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2014-04-24 15:01:09 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

'git am'able fix attached, build tested only. Let me know if you'd
like me to push and build this for devel.
Comment 1 Ville Skyttä 2014-04-24 15:01:13 EDT
Created attachment 889409 [details]
Use system qtsingleapplication instead of bundled one
Comment 2 Deji Akingunola 2014-05-20 00:02:33 EDT
Thank you for submitting this bug and providing a patch.

I have attempted to apply the patch while updating the package to the latest upstream release. But it failed to build with the patch because the current (as at this time) qtsinglespplication in Fedora is not built with Qt5. So I have disabled the patch, but will continue to monitor the system's qtsingleapplication for when it provides support for Qt5.
Comment 3 Ville Skyttä 2014-05-20 02:44:16 EDT
The other allowed alternative to getting rid of the bundling is to get an exception from FPC and mark it as appropriate in the package.

https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#Exceptions
Comment 4 Fedora Admin XMLRPC Client 2014-07-26 13:13:25 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2014-07-26 15:49:47 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Mukundan Ragavan 2014-07-26 23:34:21 EDT
I will look into this.
Comment 7 Mukundan Ragavan 2014-08-10 18:42:43 EDT
I am unable to compile with system qtsingleapplication yet. I will get this fixed as soon as I can.


In file included from texmakerapp.h:18:0,
                 from main.cpp:15:
/usr/include/QtSolutions/qtsingleapplication.h:75:49: error: 'Type' has not been declared
     QtSingleApplication(int &argc, char **argv, Type type);
                                                 ^
Makefile:1945: recipe for target '.obj/main.o' failed
make: *** [.obj/main.o] Error 1
make: *** Waiting for unfinished jobs....
In file included from texmakerapp.h:18:0,
                 from texmakerapp.cpp:21:
/usr/include/QtSolutions/qtsingleapplication.h:75:49: error: 'Type' has not been declared
     QtSingleApplication(int &argc, char **argv, Type type);
                                                 ^
Makefile:1986: recipe for target '.obj/texmakerapp.o' failed


Any input is welcome! Thanks.
Comment 8 Mukundan Ragavan 2014-12-06 23:02:29 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.