Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1091307 - TCL/TK 8.6
TCL/TK 8.6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Yoana Ruseva
ChangeAcceptedF21 SystemWideChange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-25 06:45 EDT by Jaroslav Reznik
Modified: 2014-12-08 10:22 EST (History)
3 users (show)

See Also:
Fixed In Version: tcl-8.6.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 10:22:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2014-04-25 06:45:41 EDT
This is a tracking bug for Change: TCL/TK 8.6
For more details, see: http://fedoraproject.org//wiki/Changes/f21tcl86

Update tcl/tk from 8.5 to 8.6 in Fedora 21.
Comment 1 Jaroslav Reznik 2014-07-04 06:43:29 EDT
This message is a reminder that Fedora 21 Accepted Changes Freeze Deadline is on 2014-07-08 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Freeze.

This bug should be set to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 2 Yoana Ruseva 2014-08-21 05:26:03 EDT
Hi Jaroslav, 

I wrote a beat about the changes in TCL/TK for Fedora 21. Could you have a look at it and see if it's correct or if you'd like to add anything else.

You can find the text here, under "TCL/TK 8.6":
https://fedoraproject.org/wiki/Documentation_Development_Beat?rd=Docs/Beats/Devel

Thanks a lot!

Yoana
Comment 3 Jaroslav Škarvada 2014-08-21 05:52:27 EDT
(In reply to Yoana Ruseva from comment #2)
> Hi Jaroslav, 
> 
> I wrote a beat about the changes in TCL/TK for Fedora 21. Could you have a
> look at it and see if it's correct or if you'd like to add anything else.
> 
> You can find the text here, under "TCL/TK 8.6":
> https://fedoraproject.org/wiki/Documentation_Development_Beat?rd=Docs/Beats/
> Devel
> 
> Thanks a lot!
> 
> Yoana

Hi,

thanks for doing this, it looks great. I would add the following:

tcl:
Thread-enabled Operations: A thread-enabled default build, a bundled Thread package, and new command interp cancel make Tcl 8.6 ready for your multi-threaded programming tasks.

and maybe one more for tk (but this is not important :)
Angled Text: New option -angle $degrees to $canvas create text for rotating displayed text.
Comment 4 Yoana Ruseva 2014-08-21 06:25:26 EDT
Hi, 

Added the new information, edited slightly:

https://fedoraproject.org/wiki/Documentation_Development_Beat?rd=Docs/Beats/

I replaced "thread-enabled operations" with "multi-thread operations" because of too many "enables" on the same line. Does it still make sense?

Yoana
Comment 5 Jaroslav Škarvada 2014-08-21 07:30:27 EDT
(In reply to Yoana Ruseva from comment #4)
> Hi, 
> 
> Added the new information, edited slightly:
> 
> https://fedoraproject.org/wiki/Documentation_Development_Beat?rd=Docs/Beats/
> 
> I replaced "thread-enabled operations" with "multi-thread operations"
> because of too many "enables" on the same line. Does it still make sense?
> 
> Yoana

OK, thank you.
Comment 6 Jaroslav Reznik 2014-10-07 08:23:33 EDT
This message is a reminder that Fedora 21 Change Checkpoint: 100% Code Complete Deadline (Former Accepted Changes 100% Complete) is on 2014-10-14 [1].

All Accepted Changes has to be code complete and ready to be validated in the Beta release (optionally by Fedora QA). Required bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a point of contingency plan. All incompleted Changes will be reported to FESCo on 2014-10-15 meeting. In case of any questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 7 Jaroslav Škarvada 2014-10-07 08:36:19 EDT
This feature is 100% completed.
Comment 8 Jaroslav Reznik 2014-10-13 07:11:53 EDT
Based on comment #7, moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.