Bug 1091533 - Can't install nodejs-grunt because of conflicting dependencies
Summary: Can't install nodejs-grunt because of conflicting dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nodejs-grunt
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-25 19:41 UTC by Michael Peters
Modified: 2020-11-05 09:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-05 12:05:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Peters 2014-04-25 19:41:14 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum install nodejs

nodejs-0.10.26-1.el6.x86_64 is installed

2. yum install npm

npm-1.3.6-4.el6.noarch is installed

3. yum install nodejs-grunt

Fails.

Actual results:

Fails with this message and then error:

Loaded plugins: presto
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package nodejs-grunt.noarch 0:0.4.4-1.el6 will be installed
--> Processing Dependency: npm(underscore.string) < 3 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(lodash) < 2.5 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(js-yaml) < 3 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(iconv-lite) < 1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(hooker) < 1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(grunt-legacy-util) < 0.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(getobject) < 0.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(findup-sync) < 1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(exit) < 0.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(eventemitter2) < 1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(colors) < 1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(coffee-script) < 2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(underscore.string) >= 2.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(lodash) >= 2.4.1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(js-yaml) >= 2.0 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(iconv-lite) >= 0.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(hooker) >= 0.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(grunt-legacy-util) >= 0.1.2 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(getobject) >= 0.1.0 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(findup-sync) >= 0.1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(exit) >= 0.1.1 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(eventemitter2) >= 0.4 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(colors) >= 0.6 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(coffee-script) >= 1.3 for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Processing Dependency: npm(dateformat) for package: nodejs-grunt-0.4.4-1.el6.noarch
--> Running transaction check
---> Package coffee-script.noarch 0:1.6.3-1.el6 will be installed
--> Processing Dependency: coffee-script-common = 1.6.3-1.el6 for package: coffee-script-1.6.3-1.el6.noarch
---> Package nodejs-colors.noarch 0:0.6.2-1.el6 will be installed
---> Package nodejs-dateformat.noarch 0:1.0.6-1.el6 will be installed
---> Package nodejs-eventemitter2.noarch 0:0.4.13-1.el6 will be installed
---> Package nodejs-exit.noarch 0:0.1.2-1.el6 will be installed
---> Package nodejs-findup-sync.noarch 0:0.1.3-1.el6 will be installed
---> Package nodejs-getobject.noarch 0:0.1.0-1.el6 will be installed
---> Package nodejs-grunt-legacy-util.noarch 0:0.1.2-1.el6 will be installed
---> Package nodejs-hooker.noarch 0:0.2.3-4.el6 will be installed
---> Package nodejs-iconv-lite.noarch 0:0.2.11-1.el6 will be installed
---> Package nodejs-js-yaml.noarch 0:2.1.0-3.el6 will be installed
--> Processing Dependency: npm(esprima) < 1.1 for package: nodejs-js-yaml-2.1.0-3.el6.noarch
--> Processing Dependency: npm(argparse) < 0.2 for package: nodejs-js-yaml-2.1.0-3.el6.noarch
--> Processing Dependency: npm(esprima) >= 1.0.2 for package: nodejs-js-yaml-2.1.0-3.el6.noarch
--> Processing Dependency: npm(argparse) >= 0.1.11 for package: nodejs-js-yaml-2.1.0-3.el6.noarch
---> Package nodejs-lodash.noarch 0:2.4.1-2.el6 will be installed
---> Package nodejs-underscore-dot-string.noarch 0:2.3.1-3.el6 will be installed
--> Running transaction check
---> Package coffee-script-common.noarch 0:1.6.3-1.el6 will be installed
---> Package nodejs-esprima.noarch 0:1.0.4-1.el6 will be installed
---> Package nodejs-js-yaml.noarch 0:2.1.0-3.el6 will be installed
--> Processing Dependency: npm(argparse) < 0.2 for package: nodejs-js-yaml-2.1.0-3.el6.noarch
--> Processing Dependency: npm(argparse) >= 0.1.11 for package: nodejs-js-yaml-2.1.0-3.el6.noarch
--> Finished Dependency Resolution
Error: Package: nodejs-js-yaml-2.1.0-3.el6.noarch (epel)
           Requires: npm(argparse) < 0.2
Error: Package: nodejs-js-yaml-2.1.0-3.el6.noarch (epel)
           Requires: npm(argparse) >= 0.1.11
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:

nodejs-grunt-0.4.4-1.el6 should be installed

Additional info:

Comment 1 Jamie Nguyen 2014-04-26 10:48:22 UTC
Thanks for the bug report. 

Strangely, nodejs-argparse is missing from the epel-6 repository, despite having been pushed to stable:

https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12326/nodejs-grunt-0.4.1-2.el6,nodejs-js-yaml-2.1.0-3.el6,nodejs-underscore-dot-string-2.3.1-3.el6,nodejs-argparse-0.1.15-3.el6

I'm not sure how this happened. Nonetheless, I should have picked this up myself sooner.

New updates in progress for nodejs-argparse.

Comment 2 Fedora Update System 2014-04-26 18:29:29 UTC
nodejs-argparse-0.1.15-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-argparse-0.1.15-6.el6

Comment 3 Fedora Update System 2014-04-27 17:57:22 UTC
nodejs-argparse-0.1.15-6.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 4 Fedora Update System 2014-05-08 17:25:56 UTC
nodejs-argparse-0.1.15-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-argparse-0.1.15-7.el6

Comment 5 T.C. Hollingsworth 2014-06-05 12:05:29 UTC
This should be resolved in the stable repository now.


Note You need to log in before you can comment on or make changes to this bug.