Bug 109159 - Make Splitter work with XML files
Summary: Make Splitter work with XML files
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: documentation   
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Rafael H. Schloming
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-05 06:04 UTC by Justin Ross
Modified: 2014-12-01 23:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 21:37:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Ross 2003-11-05 06:04:19 UTC
Description of problem:

Splitter is a very handy tool for generating program listings in
documentation, but it doesn't work well for XML "programs".  Two
reasons for that:

1. "<!-- @rhdoc.begin foo.sgml -->" does not work because the trailing
"-->" is not stripped away.

2. XML documents do not allow comments preceeding the <?xml?>
declaration or otherwise outside the root element.  If you want to
insert an entire XML document as an example listing, you will not be
able to bracket it with XML comments and still have working code.


Note You need to log in before you can comment on or make changes to this bug.