Bug 1091613 - No icon for Bluefish
Summary: No icon for Bluefish
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluefish
Version: 20
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1116522 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-26 13:07 UTC by Fiable.biz
Modified: 2014-07-28 03:34 UTC (History)
3 users (show)

Fixed In Version: bluefish-2.2.6-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 03:27:15 UTC


Attachments (Terms of Use)

Description Fiable.biz 2014-04-26 13:07:29 UTC
Description of problem:
After installing BlueFish in Fedora Gnome, it doesn't appear in the list of applications with GUI: typing "bluef" in the field "Type to search..." gives no result.

Version-Release number of selected component (if applicable):
2.2.5

How reproducible:
always

Steps to Reproduce:
1. Click on "Activities".
2. Click on "Type to search..." and type "bluef".

Actual results:
The only proposal is "Search the web for bluef".

Expected results:
Bluefish icon should appear.

Additional info:

Comment 1 Paul Howarth 2014-04-26 14:03:44 UTC
Strange. This works for me in both Gnome and KDE, with "Bluefish Editor" showing up when typing "bluef" in the search box.

Comment 2 fractalesque 2014-06-22 20:30:48 UTC
I had the same problem, just installed Fedora, and tried to install Bluefish. Other programs (like codeblock, or openarena) installed just fine and their icon appeared in the list, but launching bluefish through a console gave me following error:

bash: /usr/share/applications/bluefish.desktop: Permission denied

My user is an administrator, part of group wheel.

Comment 3 Paul Howarth 2014-06-23 14:07:48 UTC
(In reply to fractalesque from comment #2)
> I had the same problem, just installed Fedora, and tried to install
> Bluefish. Other programs (like codeblock, or openarena) installed just fine
> and their icon appeared in the list, but launching bluefish through a
> console gave me following error:
> 
> bash: /usr/share/applications/bluefish.desktop: Permission denied
> 
> My user is an administrator, part of group wheel.

Can you check the permissions of the installed desktop file?

$ ls -ld /usr/share/applications/bluefish.desktop /usr/share/applications /usr/share /usr /
drwxr-xr-x.  19 root root  4096 Jun 17 20:03 /
drwxr-xr-x.  12 root root  4096 Dec 22  2013 /usr
drwxr-xr-x. 314 root root 12288 May 17 01:24 /usr/share
drwxr-xr-x.   4 root root 12288 Jun 21 09:02 /usr/share/applications
-rw-r--r--.   1 root root  3266 Jun  8 11:29 /usr/share/applications/bluefish.desktop

Comment 4 fractalesque 2014-06-24 16:28:40 UTC
(In reply to Paul Howarth from comment #3)
> (In reply to fractalesque from comment #2)
> > I had the same problem, just installed Fedora, and tried to install
> > Bluefish. Other programs (like codeblock, or openarena) installed just fine
> > and their icon appeared in the list, but launching bluefish through a
> > console gave me following error:
> > 
> > bash: /usr/share/applications/bluefish.desktop: Permission denied
> > 
> > My user is an administrator, part of group wheel.
> 
> Can you check the permissions of the installed desktop file?
> 
> $ ls -ld /usr/share/applications/bluefish.desktop /usr/share/applications
> /usr/share /usr /
> drwxr-xr-x.  19 root root  4096 Jun 17 20:03 /
> drwxr-xr-x.  12 root root  4096 Dec 22  2013 /usr
> drwxr-xr-x. 314 root root 12288 May 17 01:24 /usr/share
> drwxr-xr-x.   4 root root 12288 Jun 21 09:02 /usr/share/applications
> -rw-r--r--.   1 root root  3266 Jun  8 11:29
> /usr/share/applications/bluefish.desktop


drwxr-xr-x.  18 root root  4096 Jun 24 11:29 /
drwxr-xr-x.  11 root root  4096 Dec 11  2013 /usr
drwxr-xr-x. 235 root root 12288 Jun 24 12:08 /usr/share
drwxr-xr-x.   2 root root 12288 Jun 24 12:11 /usr/share/applications
-rw-r--r--.   1 root root  3266 Apr 22 09:34 /usr/share/applications/bluefish.desktop

after re-installing bluefish from terminal I can now launch it using '$ bluefish' command, still no icon

Comment 5 Paul Howarth 2014-07-17 14:58:37 UTC
Having tried this myself, I think I've tracked down the issue. The desktop file, icon, appdata etc. are in the bluefish-shared-data package, which is required by the bluefish package, and hence gets pulled in if you install bluefish via the command line. However, if you install it via gnome-software, it installs the bluefish-shared-data package (which is where the appdata is), and that doesn't pull in the bluefish package that actually contains the program, hence it doesn't work.

The fix will be to make the two packages depend on each other, so it doesn't matter which one you try to install.

FWIW, there are two packages because the program is arch-specific and the data isn't.

Comment 6 Fedora Update System 2014-07-17 19:58:11 UTC
bluefish-2.2.6-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bluefish-2.2.6-3.fc20

Comment 7 Paul Howarth 2014-07-17 20:00:48 UTC
*** Bug 1116522 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2014-07-19 05:54:40 UTC
Package bluefish-2.2.6-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluefish-2.2.6-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8453/bluefish-2.2.6-3.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-07-28 03:27:15 UTC
bluefish-2.2.6-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fiable.biz 2014-07-28 03:34:33 UTC
Thank you.


Note You need to log in before you can comment on or make changes to this bug.