Bug 1091615 - Cannot enter encryption passphrase before upgrade due to incorrect keyboard layout
Summary: Cannot enter encryption passphrase before upgrade due to incorrect keyboard l...
Keywords:
Status: CLOSED DUPLICATE of bug 1038413
Alias: None
Product: Fedora
Classification: Fedora
Component: fedup
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-26 13:32 UTC by Michael Catanzaro
Modified: 2014-04-28 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-28 22:16:56 UTC


Attachments (Terms of Use)

Description Michael Catanzaro 2014-04-26 13:32:39 UTC
Description of problem: I'm trying to use fedup to upgrade from F20 (with updates) to rawhide. After running the command 'sudo fedup --network rawhide --nogpgcheck --instrepo http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/', I rebooted and selected the new system upgrade option in the boot menu. Now a prompt appears requesting my LUKS passphrase. Every time I type my passphrase it is rejected, even though I'm sure it's right. When I Ctrl+Alt+F2 to switch consoles, any text I type is entered in the US English keyboard layout, but I selected the Dvorak layout when I installed Fedora, and normally enter my passphrase in this layout.


Version-Release number of selected component (if applicable):

fedup-0.8.0-3.fc20
dracut-037-10.git20140402.fc20

How reproducible: Always


Steps to Reproduce:
1. Ensure your system uses LUKS encryption and is set to a non-default keyboard layout
2. Prepare an upgrade with Fedup and try to reboot into it.

Actual results: Keyboard layout at Fedup's passphrase prompt is English (US)

Expected results: Keyboard layout is the same as is normally used for the passphrase prompt

Additional info: In F18 and F19, LUKS passphrases always used the US English keyboard layout, which was nonsense. In F20 they are fixed to use the layout configured by the user. Fedup should respect this choice; otherwise, I have to work out how to translate my long passphrase from one layout to another.

Comment 1 Michael Catanzaro 2014-04-28 22:16:56 UTC

*** This bug has been marked as a duplicate of bug 1038413 ***


Note You need to log in before you can comment on or make changes to this bug.