Bug 1091632 - tw2: ParameterError: Attr param clashes with user-supplied attr
Summary: tw2: ParameterError: Attr param clashes with user-supplied attr
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-tw2-forms
Version: 20
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-26 17:29 UTC by Jan ONDREJ
Modified: 2014-05-17 06:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-17 02:32:08 UTC
Type: Bug


Attachments (Terms of Use)
Fixing patch. (369 bytes, patch)
2014-04-26 17:29 UTC, Jan ONDREJ
no flags Details | Diff

Description Jan ONDREJ 2014-04-26 17:29:03 UTC
Created attachment 890099 [details]
Fixing patch.

Description of problem:
TW2 raises exception when loading page with SubmitButton in parallel. Looks like upstream already fixed this. Attaching my patch against current Fedora tw2-forms, which works for me.

Version-Release number of selected component (if applicable):
python-tw2-forms-2.1.4.1-5.fc20.noarch

How reproducible:
sometimes, when trying parallel access

Actual results:
ParameterError: Attr param clashes with user-supplied attr: 'value'

Additional info:
https://github.com/toscawidgets/tw2.core/issues/76
https://github.com/toscawidgets/tw2.forms/commit/fea177dbb0e52d9b45c7a79fb7f7e200489d2dde

Comment 1 Fedora Update System 2014-04-28 18:06:25 UTC
python-tw2-forms-2.1.4.1-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-tw2-forms-2.1.4.1-7.el6

Comment 2 Fedora Update System 2014-04-28 18:06:40 UTC
python-tw2-forms-2.1.4.1-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-tw2-forms-2.1.4.1-7.fc19

Comment 3 Fedora Update System 2014-04-28 18:06:53 UTC
python-tw2-forms-2.1.4.1-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-tw2-forms-2.1.4.1-7.fc20

Comment 4 Ralph Bean 2014-04-28 18:15:22 UTC
Thanks, Jan.  :)

Comment 5 Fedora Update System 2014-05-17 00:05:46 UTC
python-tw2-forms-2.1.4.1-7.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-05-17 06:28:12 UTC
python-tw2-forms-2.1.4.1-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-05-17 06:29:53 UTC
python-tw2-forms-2.1.4.1-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.