Bug 109164 - /etc/init.d/iptables nod module-init-tools aware
/etc/init.d/iptables nod module-init-tools aware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-05 05:29 EST by Emmanuel Thomé
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.2.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 08:54:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes #109164 (1.35 KB, patch)
2003-11-05 05:32 EST, Emmanuel Thomé
no flags Details | Diff

  None (edit)
Description Emmanuel Thomé 2003-11-05 05:29:20 EST
Description of problem:

/etc/init.d/iptables does not cope correctly with new modutils

Version-Release number of selected component (if applicable):

1.2.8-13

How reproducible:

Run a 2.6 kernel, see how iptables fails to unload the ip_tables modules

Steps to Reproduce:
1. boot 2.6
2. service iptables start (assuming fw configured)
3. service iptables stop
  
Actual results:

Unloading iptables modules: --> FAILED, instead of OK.

Expected results:

Unloading iptables modules: --> OK

Additional info:
Comment 1 Emmanuel Thomé 2003-11-05 05:32:11 EST
Created attachment 95725 [details]
fixes #109164

Note that the version string returned by modprobe --version depends on the
kernel version, since the binary which gets eventually called by modprobe
depends on uname also...
Comment 2 Thomas Woerner 2003-12-17 08:54:28 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.