Bug 1091975 - Main page - missing rel attribute
Summary: Main page - missing rel attribute
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: jmagen@redhat.com
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-28 12:18 UTC by Martin Korbel
Modified: 2016-04-22 15:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:05:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 5836 None None None 2016-04-22 15:13:57 UTC

Description Martin Korbel 2014-04-28 12:18:13 UTC
Description of problem:
On the main page (after login), there is missing attribute "rel".

Version-Release number of selected component (if applicable):
katello-1.5.0-19
foreman-1.5.0.20-1

How reproducible:
100%

Steps to Reproduce:
1. Login into Sat6.0
2. look at html source code


Actual results:
You can find details of how to set up the proxy at
    <a href="http://www.theforeman.org/manuals/1.5/index.html#4.3.1SmartProxyInstallation" "external">Smart-Proxy Installation</a>.



Expected results:
You can find details of how to set up the proxy at
    <a href="http://www.theforeman.org/manuals/1.5/index.html#4.3.1SmartProxyInstallation" rel="external">Smart-Proxy Installation</a>.

Comment 1 RHEL Product and Program Management 2014-04-28 12:26:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Martin Korbel 2014-04-28 12:33:02 UTC
Fix reproducer:
1. Login into Sat6.0 and choose an organization.

Comment 4 Dominic Cleal 2014-05-20 16:30:49 UTC
Created redmine issue http://projects.theforeman.org/issues/5836 from this bug

Comment 5 jmagen@redhat.com 2014-05-22 08:10:20 UTC
https://github.com/theforeman/foreman/pull/1465

Comment 7 Sachin Ghai 2014-05-23 10:37:44 UTC
Verified with sat6 beta snap6 


"rel" attribute is set as below:

<p>
If you're planning to do anything more than just handle reports, you'll be in need of a smart proxy - either on this machine or elsewhere on your network. You can find details of how to set up the proxy at
<a rel="external" href="http://www.theforeman.org/manuals/1.6/index.html#4.3.1SmartProxyInstallation">Smart-Proxy Installation</a>
.
</p>


However clicking on link leads to "404 Not found"..though its a seperate issue. So moving this bz to verified.

Comment 8 Bryan Kearney 2014-07-02 14:05:03 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.