Bug 109205 - Change default value of MAX_CONNECTIONS constant
Change default value of MAX_CONNECTIONS constant
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: samba (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-05 12:02 EST by Jesus Ortega (a.k.a Nitebirdz)
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:23:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesus Ortega (a.k.a Nitebirdz) 2003-11-05 12:02:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030827

Description of problem:
The file "smbd/conn.c" contains a hard coded limitation for
connections that is causing problems with Citrix servers.

conn.c:#define MAX_CONNECTIONS 256

If there are many users connected to a Citrix Metaframe server, the
connections to shares start fo fail with the following error:

ERROR! Out of connection structures


Simply changing the value to something like 1024 and recompiling fixes
the problem, which also appears to be present in Samba 3.0 and RHEL
3.0.  Since the target market of the product is the enterprise, you
may want to consider bumping up this value.  There is an existing bug
at samba.org (see below), but I wonder if perhaps you might consider
building your RPM with this change.

https://bugzilla.samba.org/show_bug.cgi?id=716

Version-Release number of selected component (if applicable):
samba-2.2.7-3.21as

How reproducible:
Always

Steps to Reproduce:
1. Configure Windows system as Citrix Metaframe server
2. Configure shares over Samba
    

Additional info:
Comment 4 RHEL Product and Program Management 2007-10-19 15:23:49 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.