Bug 109217 - Search result links are wrong for Intermedia.
Summary: Search result links are wrong for Intermedia.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 106597
TreeView+ depends on / blocked
 
Reported: 2003-11-05 18:02 UTC by Jon Orris
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 18:46:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Orris 2003-11-05 18:02:27 UTC
Description of problem:

Intermedia searches work properly, but the links they return are
incorrect & don't redirect properly.

ex:
http://localhost:9020/redirect/?oid=%5Bcom.arsdigita.cms.contenttypes.Article%3A%7Bid%3D283%7D%5D

Comment 1 Daniel Berrange 2003-11-05 18:08:08 UTC
What is incorrect about that URL ? It look fine to me (assuming
localhost:9020 is what your server is running on). The /redirect/ is a
dedicated servlet so  doesn't need a /ccm either.

If you are getting 404s it could be that no URLFinder is registered,
but CMS should be adding a generic finder for ContentPage already.


Comment 2 Jon Orris 2003-11-05 18:46:57 UTC
D'oh. Was accessing from a different machine, so the 'localhost' bit
screwed it up.

Not a bug then, but should go in the IG.
Possibly the hostname parameter validation code should also reject
'localhost'?



Note You need to log in before you can comment on or make changes to this bug.