This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 109268 - distutils configured with wrong CC/LDSHARED etc
distutils configured with wrong CC/LDSHARED etc
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: python (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 05:44 EST by Joe Orton
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version: 2.3.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-13 08:50:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2003-11-06 05:44:44 EST
The Subversion build is broken against Python 2.3.2, because:

python -c "from distutils import sysconfig; print
sysconfig.get_config_vars('LDSHARED')[0]"

expected results:
gcc -pthread -shared

actual results: (e.g.)
x86_64-redhat-linux-gcc -pthread -shared

'CC' is likewise broken.
Comment 1 Mihai Ibanescu 2003-11-06 11:19:32 EST
That is weird, but why is it wrong? AFAICT, in the gcc package they
are exactly the same file. Hardlinked too.
Comment 2 Joe Orton 2003-11-06 11:24:25 EST
It breaks because the generated libtool script only knows what "gcc"
is, not "x86_64-redhat-linux-gcc".  (In case it wasn't clear, this is
a regression - the python 2.2 packages didn't have this bug)
Comment 3 Mihai Ibanescu 2003-11-06 11:51:25 EST
This happens because distutils parses the Makefile used to compile
python (i.e. /usr/lib/python2.3/config/Makefile), and this is the
compiler beehive used.

On my local machine, CC is correctly set to gcc - I would think it's
something from beehive that confuses python.
Comment 4 Mihai Ibanescu 2003-11-12 17:33:12 EST
python-2.3.2-5 in fc2 should fix this.
Comment 5 Joe Orton 2003-11-13 08:50:47 EST
WORKSFORME, thanks.

Note You need to log in before you can comment on or make changes to this bug.