Bug 109270 - Deleting the primary language instance of a ContentBundle
Summary: Deleting the primary language instance of a ContentBundle
Status: CLOSED DUPLICATE of bug 109754
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 108447
TreeView+ depends on / blocked
 
Reported: 2003-11-06 11:29 UTC by Carsten Clasohm
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carsten Clasohm 2003-11-06 11:29:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

Description of problem:
When a content bundle has more than one language instance, the UI
shows a "delete" link on the Languages tab for all but the currently
viewed language instance. Trying to delete the bundle's primary
language instance results in a violated assertion in
ContentBundle.removeInstance().


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a new Article
2. Go to the Languages tab and add a language instance
3. Go to the Languages tab and click on the Delete link


Actual Results:  com.arsdigita.util.AssertionError:
[com.arsdigita.cms.contenttypes.Article:{id=1052}]
equals [com.arsdigita.cms.contenttypes.Article:{id=1052}]
	at com.arsdigita.util.Assert.unequal(Assert.java:295)
	at com.arsdigita.cms.ContentBundle.removeInstance(ContentBundle.java:208)
	at
com.arsdigita.cms.ui.item.ItemLanguagesTable$InstanceDeleter.cellSelected(ItemLanguagesTable.java:160)


Expected Results:  Either the Delete link should not be shown for the
primary instance, or the current language instance should be made
primary before deleting the selected language.


Additional info:

Comment 1 Richard Li 2003-12-23 18:47:57 UTC

*** This bug has been marked as a duplicate of 109754 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.