Bug 109271 - Boot hangs during hardware detection
Boot hangs during hardware detection
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 06:29 EST by Aaron Kurtz
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 18:33:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Kurtz 2003-11-06 06:29:32 EST
Description of problem:
Installation is not a problem. When FC 1 boots, the boot process is
fine until it hits kudzu's "Checking for new hardware" message and
then freezes hard. It freezes during graphical boot and console boot.
 The keyboard fails to respond. During graphical boot, the mouse fails
to respond.

Version-Release number of selected component (if applicable):
Fedore Core 1

How reproducible:


Steps to Reproduce:
1. Boot FC 1
2. Wait for hang at "Checking for new hardware"
3. Reboot
  
Actual results:
Hung boot

Expected results:
Successful boot, similar to past RH releases.

Additional info:
Computer is a P4 with Intel motherboard, 256 MB RAM, Nvidia TNT2 video
card, Linksys Wireless PCI card and Es1371 SoundBlaster PCI card. I
will gladly provide more information if asked to.
Comment 1 Bill Nottingham 2003-11-06 10:14:04 EST
Do you have firewire?
Comment 2 Aaron Kurtz 2003-11-06 16:31:08 EST
No, no firewire. The only uncommon thing about the motherboard is 
SATA support, but RH9 didn't seem to have a problem with it.

02:06.0 Unknown mass storage controller: CMD Technology Inc Silicon 
Image SiI 3112 SATARaid Controller (rev 01)

I bypassed kudzu by booting single and FC1 seems to run perfectly 
fine, by the way. I haven't hooked any SATA drives up though.
Comment 3 Bill Nottingham 2003-11-06 16:31:47 EST
Does it hang if you run it post-boot?
Comment 4 Aaron Kurtz 2003-11-07 14:23:48 EST
No, it doesn't, and it actually doesn't hang during boot anymore.
I rebooted after changing to runlevel 3 and ran kudzu, and the only
strange thing was that it kept claiming my wireless PCI card was
missing and then offering to configure my newly found wireless PCI
card. This may be because I configured it in redhat-config-network at
first, not kudzu. I rebooted again after putting the network device
files in order and it settled down about that as well, and now
functions properly. I then set it to run during boot and it didn't
give me any problems. I'm baffled. I didn't change the hardware at all
through this.
Comment 5 Bill Nottingham 2003-11-07 18:33:15 EST
Hm, ok. Please reopen if it comes back.

Note You need to log in before you can comment on or make changes to this bug.