Bug 109279 - redhat-config-boot crashes at startup
Summary: redhat-config-boot crashes at startup
Status: CLOSED DUPLICATE of bug 109266
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-boot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-06 14:48 UTC by Eric Maryniak
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Maryniak 2003-11-06 14:48:43 UTC
Description of problem:
  redhat-config-boot crashes at startup

Version-Release number of selected component (if applicable):
  # cat /etc/redhat-release
  Fedora Core release 1 (Yarrow)
How reproducible:


Steps to Reproduce:
1. # redhat-config-boot
2.
3.
  
Actual results:
Component: redhat-config-boot
Version: 0.1.6
Summary: TB2e18078e boot_gui.py:238:writeBootFile:IndexError: list
index out of range
Traceback (most recent call last):
  File
"/usr/lib/python2.2/site-packages/rhpl/firstboot_gui_window.py", line
83, in okClicked
    if self.apply():
  File
"/usr/src/build/321181-i386/install/usr/share/firstboot/modules/boot_gui.py",
line 197, in apply
    self.writeBootFile(num)
  File
"/usr/src/build/321181-i386/install/usr/share/firstboot/modules/boot_gui.py",
line 238, in writeBootFile
    if tokens[0].find("=") >= 0:
IndexError: list index out of range

Local variables in innermost frame:
defaultset: 1
timeoutset: 1
i: 12
self: <boot_gui.BootWindow instance at 0x8a9015c>
lines: ['# grub.conf generated by anaconda\n', '#\n', '# Note that you
do not have to rerun grub after making changes to this file\n', '#
NOTICE:  You have a /boot partition.  This means that\n', '#         
all kernel and initrd paths are relative to /boot/, eg.\n', '#       
  root (hd0,0)\n', '#          kernel /vmlinuz-version ro
root=/dev/md1\n', '#          initrd /initrd-version.img\n',
'#boot=/dev/hda\n', 'default=0\n', 'timeout=10\n',
'splashimage=(hd0,0)/grub/splash.xpm.gz\n', '\n', 'title Fedora Core
(2.4.22-1.2115.nptlsmp)\n', '\troot (hd0,0)\n', '\tkernel
/vmlinuz-2.4.22-1.2115.nptlsmp ro root=/dev/md1 vga=7 acpi=off\n',
'\tinitrd /initrd-2.4.22-1.2115.nptlsmp.img\n']
iter: <GtkTreeIter at 0x8c68e48>
tokens: []
toplevel: {}
miceDict: {}
num: 0
fd: <closed file '/etc/grub.conf', mode 'r' at 0x8c69c50>
timeout: 10
line: 

Expected results:


Additional info:

Comment 1 Harald Hoyer 2003-11-06 14:58:09 UTC

*** This bug has been marked as a duplicate of 109266 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.