Bug 109296 - high CPU usage
high CPU usage
Status: CLOSED WONTFIX
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 12:23 EST by Bryan Che
Modified: 2007-03-27 00:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 10:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file (165.53 KB, application/octet-stream)
2003-11-18 14:52 EST, Bryan Che
no flags Details

  None (edit)
Description Bryan Che 2003-11-06 12:23:18 EST
I have a 1.6 GHz P4M with 768 MB of RAM.  Often, when I run eclipse,
it ties up the entire CPU until I kill the program.  This seems to
happen most often when problems occur in plugins.

When running the standard eclipse 2.1.2 using the Sun 1.4.2_02 JVM, I
don't have any problems with the CPU.
Comment 1 Tom Tromey 2003-11-10 12:32:58 EST
Does anything appear in workspace/.metadata/.log?
Exceptions are sometimes logged there.
Comment 2 Tom Tromey 2003-11-11 16:45:08 EST
Also, what eclipse RPM are you using?
And on which platform/OS?
Comment 3 Bryan Che 2003-11-18 14:42:52 EST
eclipse-2.1.0-22

#uname -a
Linux localhost.localdomain 2.4.21-4.EL #1 Fri Oct 3 18:13:58 EDT 2003
i686 i686 i386 GNU/Linux

Comment 4 Bryan Che 2003-11-18 14:52:54 EST
Created attachment 96044 [details]
log file

Here is my eclipse log file.  There are a number of errors in there--I'm not
sure which ones might have contributed to the cpu problem.
Comment 5 Jeremy Handcock 2003-11-24 11:37:39 EST
I had a look at your log file.  It looks like the perforce plugin may
be giving you some problems (some NPEs in net.sourceforge.perforce.*).

When you run eclipse, how are you starting it up?  Your log file seems
to indicate that you are using the Sun JVM.
Comment 6 Tom Tromey 2003-11-24 17:41:14 EST
We might not see a gcj entry in the .log file if it hangs
without ever giving an exception.  So the absence of this
in the .log file isn't necessarily indicative.

I haven't been able to reproduce this.  I've had a gcj-eclipse
open for several days (4 or 5), with many projects (PDE, JDT,
and CDT).

Note You need to log in before you can comment on or make changes to this bug.