Bug 109313 - /etc/pam.d/smtp file being deleted when postfix installed
Summary: /etc/pam.d/smtp file being deleted when postfix installed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-06 19:45 UTC by Clifford Perry
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-11 13:50:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
command output showing issue (6.93 KB, text/plain)
2003-11-06 19:47 UTC, Clifford Perry
no flags Details

Description Clifford Perry 2003-11-06 19:45:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030708

Description of problem:
To my understanding the alternatives system is designed for ease of
switching between alternative major applications, such as printer
system or MTA used on the server with minimal need for reconfiguration
by the admin/user. 

Currently when you install both postfix and sendmail onto a server,
sendmail is unable to perform authentification via
smtp_auth/saslauthd/pam due to the fact that the file installed by the
sendmail rpm (/etc/pam.d/smtp) is being deleted by the alternatives
system as soon as postfix adds the /etc/pam.d/smtp file into the
alternatives system. 

Reviewing the rpm post install script for postfix and sendmail, or
just looking at the output of alternatives --display mta you will see
that postfix adds this file into the alternatives system, but sendmail
does not. 

Since the contents of the /etc/pam.d/smtp file installed by sendmail
and the contents of the /etc/pam.d/smtp.postfix file installed by
postfix are identical, can you make a decission on either of the
following:

1 - remove this line from postfix rpm's post install script (since
both postfix AND sendmail in essance use the same file and config):

        --slave /etc/pam.d/smtp mta-pam /etc/pam.d/smtp.postfix \

2 - add a similar line to the sendmail rpms post install script and
have it install the /etc/pam.d/smtp file as /etc/pam.d/smtp.sendmail. 

I have included in the additional info section output showing
install/removal of the sendmail and postfix rpms and running rpm
verify and listing using alternatives system of the MTA in hope that
it helps see this clearer. 

Thanks
Cliff. 

Version-Release number of selected component (if applicable):
sendmail-8.12.10-1

How reproducible:
Always

Steps to Reproduce:
1.Install Sendmail and Postfix - order doesnt matter
2. Run rpm verify on sendmail and notice missing file
3. SMTP AUTH (using plain) for sendmail is broken and fails
    

Additional info:

Comment 1 Clifford Perry 2003-11-06 19:47:02 UTC
Created attachment 95769 [details]
command output showing issue

Attached file is copy/paste into file of me running various sequance of
commands to show this bug in action.

Comment 2 Florian La Roche 2003-12-11 13:50:44 UTC
I have added an alternatives entry for 8.12.10-4 for this file in case
it changes form the postfix one in the future.

Thanks for this detailed bug-report,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.