Bug 1093149 - GNU Make segfaults on $(eval) in parallel
Summary: GNU Make segfaults on $(eval) in parallel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: make
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Patsy Griffin
QA Contact: Martin Cermak
Clayton Spicer
URL:
Whiteboard:
Depends On:
Blocks: 1172231 1271375
TreeView+ depends on / blocked
 
Reported: 2014-04-30 17:56 UTC by Joe Sapp
Modified: 2016-05-10 21:14 UTC (History)
4 users (show)

Fixed In Version: make-3.81-21.el6
Doc Type: Release Note
Doc Text:
Parallel builds no longer terminate unexpectedly due to `$(eval)` constructs Previously, a bug caused the *make* utility to terminate unexpectedly when executing parallel builds containing `$(eval)` constructs. This has now been fixed, and parallel builds no longer crash due to this bug.
Clone Of:
Environment:
Last Closed: 2016-05-10 21:14:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Sample Makefile that segfaults when built in parallel (386 bytes, text/plain)
2014-04-30 17:56 UTC, Joe Sapp
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNU Savannah 20033 0 None None None Never
Red Hat Product Errata RHBA-2016:0827 0 normal SHIPPED_LIVE make bug fix update 2016-05-10 22:40:53 UTC

Description Joe Sapp 2014-04-30 17:56:02 UTC
Created attachment 891265 [details]
Sample Makefile that segfaults when built in parallel

Description of problem:
GNU Make 3.81 issues a segmentation fault when run in parallel on a Makefile with an $(eval) construct.  S

Version-Release number of selected component (if applicable):
1:3.81-20.el6

How reproducible:
Not sure, but seems to be often.

Steps to Reproduce:
1. Download attached Makefile.
2. Run `make setup`
3. Run `make -j2`

Actual results:
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709
Segmentation fault (core dumped)

Expected results:
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709
tyty da39a3ee5e6b4b0d3255bfef95601890afd80709

Additional info:
See https://savannah.gnu.org/bugs/?20033 for a sample Makefile and proposed patch.
Apparently this has been fixed in 3.82.

Comment 10 errata-xmlrpc 2016-05-10 21:14:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0827.html


Note You need to log in before you can comment on or make changes to this bug.