Bug 109348 - Cannot install from hard drive
Cannot install from hard drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 18:06 EST by Isaac-Lew
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:25:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaac-Lew 2003-11-06 18:06:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031022

Description of problem:
I am unable to install from either an extended vfat partition (hda10)
or an ext3 partition (hda12).  The installer states that it cannot
find the CD images.

Version-Release number of selected component (if applicable):
Fedora Core 1.0

How reproducible:
Always

Steps to Reproduce:
1. Using boot.iso extracted from CD 1, I made a boot CD.
2. Rebooted the system to boot from the boot CD.
3. Selected Hard Drive as the install method.
4. Selected /dev/hda10 as the partition holding the CD images.
    

Actual Results:  Error message:
"Device /dev/hda10 does not appear to contain Red Hat CDROM images".

Expected Results:  Install should proceed as normal.

Additional info:

I was also unable to install Fedora Test 3. Fedora Test 1 & 2
installed normally via this method.
Comment 1 Jeremy Katz 2003-11-06 18:08:46 EST
Silly question -- did you specify the right partition and directory
that holds the ISO images?  Which images did you place there?  Also,
what messages are there on tty3?
Comment 2 Isaac-Lew 2003-11-06 19:24:41 EST
Yes I did.  I placed the 3 yarrow CD isos (md5sum came up correctly)
in a directory called fedora.  I also tried moving them to the
top-level directory, that did not work.  Here is what tty3 says:

* partition /dev/hda10 selected
* mounting device hda10 for hard drive install
* mntloop loop7 on /tmp/loopimage as /tmp/hdimage//boot.iso fd is 13
* umounting loopback /tmp/loopimage loop7
* mntloop loop7 on /tmp/loopimage as
/tmp/hdimage//yarrow-i386-disc3.iso fd is 13
* umounting loopback /tmp/loopimage loop7
* mntloop loop7 on /tmp/loopimage as
/tmp/hdimage//yarrow-i386-disc1.iso fd is 13
* umounting loopback /tmp/loopimage loop7
* mntloop loop7 on /tmp/loopimage as
/tmp/hdimage//yarrow-i386-disc2.iso fd is 13
* umounting loopback /tmp/loopimage loop7
Comment 3 Jeremy Katz 2003-11-06 19:39:21 EST
Hmmm, from this it looks almost like the stamp for the ISOs didn't
match what was in your boot disc.  Can you make sure that you booted
from the right CD (since I make that mistake all the time :)
Comment 4 chris 2003-11-11 11:34:18 EST
In case it's relevant - I had somewhat similar symptoms when trying to
install over HTTP/FTP: after retrieving stage2.img, I got a box saying
"The Fedora Core installation tree in that directory does not seem to
match your boot media".  But I had made the boot disks from the
images/ subdirectory in that installation tree!

Downloading the ISO images (from the same place) and then writing them
to CDs and installing from them worked fine.
Comment 5 delnaaz 2004-02-27 05:53:20 EST
Hi! I too seem to be getting the same error message of hard disk not 
holding the cd images while trying the installation fom my hard 
drive. i have dumped all the cd files to my hard drive but it dosent 
seem to work. also when i try to copy the image files to a floppy 
disk it gets corrupted. however if i install using the cd i do not 
face any such problems. how do i tackel this problem. URGENT HELP 
needed! Thx.
Comment 6 Phoenix 2004-03-01 07:52:57 EST
try installing a CD drive :)
Comment 7 Jeremy Katz 2004-10-05 11:25:28 EDT
This should be fixed in our current code.

Note You need to log in before you can comment on or make changes to this bug.