Bug 109355 - xemacs crashes immediately with segv on ia64
xemacs crashes immediately with segv on ia64
Status: CLOSED DUPLICATE of bug 106744
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xemacs (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 18:54 EST by Ben Woodard
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Woodard 2003-11-06 18:54:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
xemacs crashes immediately upon startup on ia64. I am unable to try it
on a machine with a local X server. So I don't know if it matters that
I'm on a RH9 ia32 box with SSH X forwarding.

Version-Release number of selected component (if applicable):
xemacs-21.4.13-2.ent

How reproducible:
Always

Steps to Reproduce:
1. ssh -X to a ia64 machine
2. xemacs
3.
    

Actual Results:  49 [ben@xenophanes Kernels]$ ssh tdevi
ben@tdevi's password:
news:
tdevi@ben:xemacs
                                                                     
          
Fatal error (11).
                                                                     
          
Your files have been auto-saved.
Use `M-x recover-session' to recover them.
                                                                     
          
Your version of XEmacs was distributed with a PROBLEMS file that  may
describe
your crash, and with luck a workaround.  Please check it first, but do
report
the crash anyway.  Please report this bug by invoking M-x
report-emacs-bug,
or by selecting `Send Bug Report' from the Help menu.  If necessary, send
ordinary email to `crashes@xemacs.org'.  *MAKE SURE* to include the XEmacs
configuration from M-x describe-installation, or equivalently the file
Installation in the top of the build tree.
                                                                     
          
*Please* try *hard* to obtain a C stack backtrace; without it, we are
unlikely
to be able to analyze the problem.  Locate the core file produced as a
result
of this crash (often called `core' or `core.<process-id>', and located in
the directory in which you started XEmacs or your home directory), and
type
                                                                     
          
  gdb /usr/src/build/307042-ia64/BUILD/xemacs-21.4.13/src/xemacs core
                                                                     
          
then type `where' at the debugger prompt.  No GDB on your system?  You may
have DBX, or XDB, or SDB.  (Ask your system administrator if you need
help.)
If no core file was produced, enable them (often with `ulimit -c
unlimited'
in case of future recurrance of the crash.
                                                                     
          
Lisp backtrace follows:
                                                                     
          
Segmentation fault


Expected Results:  xemacs starts up.

Additional info:

Seems to work fine from a RHE3 ia32 box.
Standard gnu-emacs works just fine.
Comment 1 Ben Woodard 2003-11-06 18:58:33 EST
If I do a strace one of the last things that shows up is it opening
/etc/passwd. That may be a clue as to what it is doing.

open("/etc/passwd", O_RDONLY)           = 5
fcntl(5, F_GETFD)                       = 0
fcntl(5, F_SETFD, FD_CLOEXEC)           = 0
fstat(5, {st_mode=S_IFREG|0644, st_size=14573, ...}) = 0
mmap(NULL, 65536, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x2000000003adc000
read(5, "root:x:0:0:root:/root:/bin/bash\n"..., 16384) = 14573
close(5)                                = 0
munmap(0x2000000003adc000, 65536)       = 0
rt_sigaction(SIGALRM, {0x40000000003cd540, [], SA_INTERRUPT},
{0x40000000003cd540, [], SA_INTERRUPT}, 8) = 0
setitimer(ITIMER_REAL, {it_interval={0, 0}, it_value={0, 0}}, NULL) = 0
rt_sigaction(SIGCHLD, {0x40000000003cf280, [], SA_INTERRUPT},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGWINCH, {0x40000000003cde90, [], SA_INTERRUPT},
{SIG_DFL}, 8) = 0--- SIGSEGV (Segmentation fault) @ 200000000142ba40
(200000000142ba40) ---
rt_sigprocmask(SIG_UNBLOCK, [SEGV], NULL, 8) = 0
rt_sigaction(SIGSEGV, {SIG_DFL}, {0x200000000147e2d0, [],
SA_INTERRUPT}, 8) = 0
write(2, "\nFatal error (11).\n\n", 20) = 20
write(2, "Your files have been auto-saved."..., 888) = 888
write(2, "/usr/src/build/307042-ia64/BUILD"..., 58) = 58
write(2, " core\n\nthen type `where\' at the "..., 278) = 278
write(2, "\nLisp backtrace follows:\n\n", 26) = 26
getpid()                                = 3091
kill(3091, SIGSEGV)                     = 0
--- SIGSEGV (Segmentation fault) @ 2000000000c11be2 (1fcf00000c13) ---
+++ killed by SIGSEGV +++
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.