Bug 109364 - The configuration script filename is wrong
Summary: The configuration script filename is wrong
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rp-pppoe (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-07 02:33 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 22:29:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-11-07 02:33:09 UTC
Description of problem:
I am trying to create an xDSL Connection by using
redhat-config-network, I give the program some parameter just like
"Login name", "Password" and etc, also give the "Provider name" as
"ADSL", after I press OK, the system named the connection as "ppp0"
and the connection can be activated correctly. But after the system
reboot, the connection cannot be up either during the boot process or
after the boot process by running "ifup ppp0", it says configuration
for ppp0 not found. The redhat-config-network created scripts in
/etc/sysconfig/... as "ifcfg-ADSL", but actually it should be
"ifcfg-ppp0", after rename all three "ifcfg-ADSL" in the directory to
"ifcfg-ppp0", the problem solved. Please fix the bug.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:


Steps to Reproduce:
1. Run redhat-config-network
2. Create an xDSL Connection, set the Provider name to "ADSL", and
press OK.
3. Reboot the system.
  
Actual results:
The new created conneciton cannot be up.

Expected results:
It should be up during the system boot process or after the system
booted, run "ifup ppp0".

Additional info:
Please rename all ifcfg-ADSL to ifcfg-ppp0, the problem would be solved.

Comment 1 Harald Hoyer 2003-11-07 09:30:38 UTC
cc to Than: Are the initscripts fixed?

Comment 2 Ngo Than 2003-11-12 20:11:48 UTC
you have to upgrade rp-pppoe to 3.5-9. It should fix this problem.

If it's not yet in rawhide, you can download it from
ftp:/people.redhat.com/than/Fedora/

Please let me if it works for you. thanks



Comment 3 rog 2004-01-11 08:47:01 UTC
Using 3.5-9 with X GUI "Internet Configuration Wizard" does not fix
problem here (the wizard "Nickname" field (not ppp0) is appended to
"ifcfg-" . 

Additional comment:
Is there a check for existance of ifcfg-eth# where eth# is the nic
interface that ppp will bind to?

If an eth# entry exists in /etc/modules.conf (or kernel) but no
corresponding entry exists in /etc/sysconf/network/scripts then ppp
may fail at startup (as the eth# will not have been pre-initialised)? 

Comment 4 Harald Hoyer 2004-06-04 10:16:29 UTC
reassigning to Than

Comment 5 Ngo Than 2004-10-08 22:29:27 UTC
as i know it's already fixed in fc2 current release. please reopen it 
again if it still appears. Thanks 


Note You need to log in before you can comment on or make changes to this bug.