Bug 109377 - 'F8' key doesn't trigger the popup screen
'F8' key doesn't trigger the popup screen
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-11-07 06:03 EST by Xavier Bachelot
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-11-19 08:54:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Xavier Bachelot 2003-11-07 06:03:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
When logged on a vnc server, pressing F8 shows a popup allowing to
send events to the server (like ctr-alt-del) or copy the clipboard
from local to remote, or quit the viewer, etc...

Actually, pressing F8 does nothing :-(

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect to a vncserver
2. Press F8

Actual Results:  No popup

Expected Results:  A popup should appear, allowing to send
ctr-alt-del, send F8, quit the viewer, etc...

Additional info:
Comment 1 Tim Waugh 2003-11-07 06:11:50 EST
Works for me, but you need to give me much more information.  What is
the server running, which client are you running and on what machine, etc.
Comment 2 Xavier Bachelot 2003-11-07 06:25:02 EST
the vncviewer is running on Fedora Core 1 on an i586. Version
the vnc server is running on Windows NT4. Version 3.3.3-r9.
It does not work either with vnc server 3.3.7 running on Windows ME
nor with vnc server 3.3.7 running on Windows 2K.
Comment 3 Tim Waugh 2003-11-07 07:05:42 EST
How are you running the VNC viewer though?  Are you running a Java
applet in a browser, or using the native client?

If the native client, are you running it from the menu or the command
line, and if the command line what options, etc?
Comment 4 Xavier Bachelot 2003-11-07 08:12:30 EST
I'm running it through the command line without any option.
The command line is 'vncviewer hostname' with hostname being a
resolvable name indeed.

Also it works fine if I revert vnc to the RHL 9 version (vnc-3.3.3r2-47)
Comment 5 Tim Waugh 2003-11-07 08:21:07 EST
What desktop environment are you using?  GNOME, for instance?
Comment 6 Xavier Bachelot 2003-11-07 08:35:43 EST
nope, KDE. The box has been upgraded from RHL 8.0, and from RHL 7.3
before that IIRC. I don't know if that matters though...
Comment 7 Tim Waugh 2003-11-07 08:57:38 EST
Do you have a short-cut set for F8?  Look in your KDE preferences
Comment 8 Xavier Bachelot 2003-11-07 09:06:30 EST
Comment 9 Tim Waugh 2003-11-11 18:19:35 EST
Something in your .Xresources file?
Comment 10 Xavier Bachelot 2003-11-12 04:31:27 EST
.Xresources don't even exist.
I don't think it's related to settings because if I uninstall
vnc-4.0-0.beta4.3 and then install vnc-3.3.3r2-47 (taken from RHL 9),
everything works as expected (F8 triggers the popup window).
Comment 11 Tim Waugh 2003-11-12 04:34:48 EST
Is this a fresh install?

I haven't seen this problem myself, or any other reports of it, and I
can't think what might cause it.
Comment 12 Xavier Bachelot 2003-11-12 04:50:33 EST
no it's not a fresh install (see comment #6)

I'll try to reproduce this on a fresh install and I'll let you know
Comment 13 Tim Waugh 2003-11-12 04:57:45 EST
You could first try just adding a new user on that machine to see if
it happens for all users.
Comment 14 Xavier Bachelot 2003-11-12 05:02:30 EST
no luck either with a new user
Comment 15 Xavier Bachelot 2003-11-12 09:47:50 EST
Hi again Tim :-)
I just tried with a fresh install of FC1 and I still get the very same
behaviour (F8 does not work with vnc 4, works with vnc 3.3)

I also tried to upgrade the vncserver to vnc-4.0beta4, but it makes no

Switching to gnome (on the client) does not make any difference either.
Comment 16 Tim Waugh 2003-11-14 12:59:34 EST
About about turning off NumLock?
Comment 17 Tim Waugh 2003-11-17 12:48:06 EST
Er.. I meant: How about turning off NumLock?
Comment 18 Xavier Bachelot 2003-11-17 12:53:47 EST
You got it :-)

F8 doesn't trigger the popup when NumLock is on
but F8 does trigger the popup when NumLock is off

Thx :-)
Comment 19 Tim Waugh 2003-11-19 08:54:04 EST
An update has been released to fix this problem.

Note You need to log in before you can comment on or make changes to this bug.