Bug 109386 - With proprietary NVIDIA drivers glxgears shows DRI warning
With proprietary NVIDIA drivers glxgears shows DRI warning
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 07:33 EST by Gérard Milmeister
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 16:21:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2003-11-07 07:33:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030701 Galeon/1.3.10

Description of problem:
NVIDIA drivers 4496.
glxgears show warning:
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
For this driver the Load "dri" in XF86Config is
commented out, as it doesn't need it. There doesn't seem
to be any averse effects. All OpenGL apps seem
to work. However on RH9 there was no such warning.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
1. Install NVIDIA proprietary drivers
2. run glxgears

Additional info:
Comment 1 Gérard Milmeister 2003-11-07 13:10:15 EST
From the mailing list:
It seems that the files in /usr/X11R6/lib/tls must be removed.
It did it and the warning does not occur anymore.
Comment 2 Mike A. Harris 2003-11-07 16:21:53 EST
This is not a bug.  Please join our mailing lists for technical support
help, and read the archives.
Comment 3 Mike A. Harris 2003-11-09 04:15:19 EST
Actually, that is not the correct solution.

"rpm -e --nodeps XFree86-Mesa-libGL" is the proper solution, at
least until Nvidia fixes their driver installation to be correct
and rpm friendly.

Note You need to log in before you can comment on or make changes to this bug.