Bug 109389 - Anaconda hangs on libgcc
Anaconda hangs on libgcc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 08:13 EST by Piotr Wojciechowski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Wojciechowski 2003-11-07 08:13:58 EST
Description of problem:
Anaconda installer hangs during libgcc instalation (also in graphics
and text mode). Packet instalation status is 100% but installer hangs.
You can use CTRL+ALT+Backspace to kill X (if in graphic mode) and then
reboot, but no other package were installed. Problem was found while
installing from CD and FTP, no other source was tested.

Version-Release number of selected component (if applicable):


How reproducible:
Every installation on this machine.

Steps to Reproduce:
1. Boot from CD
2. Start instalation
3. Wait for libgcc package
  
Actual results:
Anaconda stops

Expected results:
Pass installing this package and install another

Additional info:
Machine is a laptop Dell C600
Intel Pentuim III 700
128 MB DRAM
ATI Mobility M3
ESS Maestro 3i
3Com Integrated 10/100 PCI
HDD Hitachi DK23DA-20
Comment 1 Michael Young 2003-11-07 09:14:17 EST
Did you check the CDs first, eg. by booting linux mediacheck , or
check the md5sums on the ISOs? This could be a case of bad download.
Comment 2 Piotr Wojciechowski 2003-11-07 13:12:33 EST
Yes both. All passed on this machine and also on the other.
Comment 3 Jeremy Katz 2003-11-10 15:57:35 EST
Doe it work better if you boot with 'linux allowcddma'?
Comment 4 Piotr Wojciechowski 2003-11-10 17:21:13 EST
The situation is very complex. Me and my friend are made several tests
(probes of instalations or upgrades form RH9), and have recive more
than this error. Here is summary:
1) hangs after installing libgcc
2) Before installing packages anaconda crashes with message
"(anaconda) - cannot allocate memory"
3) When we used Your option anaconda crashed after installing
glibc-common with this error message:

rpmdb: /mnt/sysimage/var/lib/rpm/Name: No such file or directory
rpmdb: /mnt/sysimage/var/lib/rpm/Name: cannont sync: No such file or
directory
install exited abnormally
sending termination signals
sending kill signals

Situations 1) and 2) are exists when running anaconda also in text and
graphics mode, with nofb or nousb options.
Comment 5 Piotr Wojciechowski 2003-12-07 09:32:29 EST
Pavel Cernik <dunric@centrum.cz> reported me that he had the same bug.
Instalation hangs on libgcc. Here is his hardware configuration:

notebook Acer TravelMate 529TXV
CPU: Pentium III (Coppermine) 700MHz
HDD: IBM DJSA-220 20GB
DVD-ROM: Toshiba SD-C2402
VGA: ATI Rage Mobility M1
RAM: 128MB

He tries disabling dma, skipping hw probing but wihout any effect.
Comment 6 Kevin Kofler 2004-05-22 12:52:36 EDT
I am hitting this during a FC1->FC2 upgrade. 
 
Methods used: 
* first attempt: HD install using loadlin after booting from a WinMe 
bootdisk 
* further attempts: HD install using Grub 
All attempts were done in text mode because Anaconda refused to use 
graphics mode on my system (probably because of the graphics card 
which is not supported by DRI and for which I have to turn DRI off to 
get X to run). 
 
Hardware configuration: 
CPU: PIII 733 MHz 
RAM: 128 MB 
HDD: IBM 40 GB (I can look up the exact model number if you need it.) 
VGA: ATI Rage Fury Maxx 
 
Software configuration: RHL 7.3 upgraded to FC1, a few packages from 
fedora.us and Livna installed. 
 
What happened: 
My first attempts to upgrade all hung at 100% of libgcc. The system 
did not just lockup, it spontaneously rebooted. There was no error 
message, just the usual Linux kernel shutdown messages ("sending 
termination signals... done" and so on). I then tried to complete the 
libgcc upgrade by hand (I had both versions of libgcc installed, so I 
removed the FC1 version using Synaptic), only to hit the exact same 
failure mode again on glibc-common (proceeds to 100%, then the kernel 
reboots). 
 
Could this be caused by not enough RAM? All the reports here 
(including mine) are with 128 MB RAM. I know this is below "minimum 
for graphical", but this is above "minimum for text mode", so I'd 
expect Anaconda to at least install... (Also note that I can use KDE 
fine under FC1 even with 128 MB RAM.) 
Comment 7 Kevin Kofler 2004-05-22 12:55:49 EDT
PS: I also tried a rpm --rebuilddb on my FC1 system, and that didn't 
fix the problem (still hangs on glibc-common). 
Comment 8 Kevin Kofler 2004-05-29 09:19:49 EDT
Sorry, I won't be able to debug this any further, because I ended up 
doing the upgrade (successfully) with apt-rpm.
Comment 9 Jeremy Katz 2004-10-05 11:27:09 EDT
This should be happier with newer releases.
Comment 10 Kevin Kofler 2005-03-12 17:36:07 EST
I can confirm this is fixed in FC3, at least on my machine. Thanks!

Note You need to log in before you can comment on or make changes to this bug.