Bug 109396 - (sata) Installation fails when installing package on a 120GB SAT drive
(sata) Installation fails when installing package on a 120GB SAT drive
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 08:59 EST by Michael Hoodes
Modified: 2013-07-02 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:20:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error text that was generated by anaconda at installation failure (620.49 KB, text/plain)
2003-11-07 09:02 EST, Michael Hoodes
no flags Details

  None (edit)
Description Michael Hoodes 2003-11-07 08:59:49 EST
Description of problem:
When installing, installation fails after packages have been 
chosen by failing to ignore partitions at the very end of the 
SAT Drive. I have tryed installing on pure IDE (with SAT in system)
and have also changed the dev count on the SAT drive from 20 (Kernel
Max) to 19 and the error still occurs.   I am unable to install 
Fedora. 

Version-Release number of selected component (if applicable):
Core 1.

How reproducible:

Fails every time. 

Steps to Reproduce:
1. Define a SAT drive with 19-20 partitions.
2. Install WINXP on Primary SAT, Linux Distros on other partions
and define Linux (EXT3) partions to be used for /home /usr/local
etcetera.
3. Try installing Fedora (Booting from CD)
  
Actual results:

Install fails with a reboot.

Expected results:

Installation of selected packages. 

Additional info:

My installation is a P4 2.4Ghz, 1GB Ram, 120GB SAT, 60GB IDE with a
Radeon 9200 card w/128mb
Comment 1 Michael Hoodes 2003-11-07 09:02:24 EST
Created attachment 95793 [details]
Error text that was generated by anaconda at installation failure
Comment 2 Michael Hoodes 2003-11-07 12:27:52 EST
Looking at Bugzilla (I didn't see it when I posted) it appears that 
this is related to bug 56244 (Fdisk can't see more than 16 partitions).
Since my SAT drive is accessed with SCSI (i.e. it's mounted as sdh).
My other Linux distro's (Debian) mount it as hdg ???  but it permits
20 which I saw as the ide device maximum.  I will try later on today
or this weekend to reduce my 120GB to 16 partitions.  I am still
leaving this open as I would like to install with my SAT kept at 
20 partitions.  
Thanks. 
Michael  
Comment 3 Jeremy Katz 2003-11-10 15:58:35 EST
This is a kernel limitation, not the installer.
Comment 4 Michael Hoodes 2003-11-10 18:28:14 EST
Jeremy, 
Thanks for the info. I realize it's a kernel limitation and 
incidentally for me who's a multi-linux user it's a shock not
only that the SAT drive is treated as a true SCSI thus it's 16 device
limitation but that the number of entries in /dev/ for the sat drive
seems to be limited to 16 in Redhat, 20 in Debian and if I use the 
64 limit (stated elsewhere) in Redhat for IDE devices I will have 
incompatibilities in other distros... But this is rambling. 

I really do not know if the Fedora installer needs to know all the
partitons on a drive but it shouldn't fail if that happens. I don't
think that it was the grub code but the install that did fail on a
drive which wasn't the installation drive when it simply should have
continued.



Comment 5 Michael Hoodes 2003-11-10 20:12:55 EST
I have limited my SAT 120GB drive to 16 Partitions and Ananconda 
still fails when trying to install packages. Other information -  
My primary partion on the SAT 120GB is NTFS.  I tried to install  
to a normal IDE disk but install fails with error message on  
16th partition.   
 
Please let me know if you want additional info. 
Comment 6 Jeff Garzik 2004-03-03 03:20:08 EST
This is indeed a SCSI limitation, and not something that can be
changed easily.  It will be resolved in late 2.6.x or early 2.7 when
SATA moves away from SCSI.

Note You need to log in before you can comment on or make changes to this bug.