Bug 1094037 - [abrt] system-config-printer: newprinter.py:3849:getNPPPD:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 88: ordinal not in range(128)
Summary: [abrt] system-config-printer: newprinter.py:3849:getNPPPD:UnicodeDecodeError:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:779054d820c8bbbfb150992a041...
: 1116507 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-04 15:36 UTC by dwizz.donowin
Modified: 2014-07-10 00:24 UTC (History)
3 users (show)

Fixed In Version: system-config-printer-1.4.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-10 00:24:02 UTC


Attachments (Terms of Use)
File: backtrace (1.14 KB, text/plain)
2014-05-04 15:36 UTC, dwizz.donowin
no flags Details
File: environ (2.30 KB, text/plain)
2014-05-04 15:36 UTC, dwizz.donowin
no flags Details

Description dwizz.donowin 2014-05-04 15:36:40 UTC
Description of problem:
Menu Nouvelle impirmante
dans 
Choisissez un pilote
utilisation du fichier PPD EEPSON_EPL-6200L2.ppd

Version-Release number of selected component:
system-config-printer-1.4.3-2.fc19

Additional info:
reporter:       libreport-2.2.1
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
dso_list:       system-config-printer-libs-1.4.3-2.fc19.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.13.9-100.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
newprinter.py:3849:getNPPPD:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 88: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/newprinter.py", line 912, in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/newprinter.py", line 1459, in nextNPTab
    self.ppd = self.getNPPPD()
  File "/usr/share/system-config-printer/newprinter.py", line 3849, in getNPPPD
    err += stdout
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 88: ordinal not in range(128)

Local variables in innermost frame:
e: RuntimeError('ppdOpenFile failed',)
err: u'Impossible de lire le fichier PPD. Ceci est peut-\xeatre d\xfb aux raisons suivantes\xa0:\n'
stdout: '/home/francois/EEPSON_EPL-6200L2.ppd: FAIL\n      **FAIL**  Unable to open PPD file - Ent\xc3\xaate PPD-Adobe-4.x manquant on line 1.\n                REF: Page 42, section 5.2.\n'
self: <NewPrinterGUI object at 0x306dcd0 (newprinter+NewPrinterGUI at 0x324cf40)>
ppd: None
filename: '/home/francois/EEPSON_EPL-6200L2.ppd'
p: <subprocess.Popen object at 0x3ce5cd0>
stderr: ''
err_title: u'Erreur PPD'

Comment 1 dwizz.donowin 2014-05-04 15:36:45 UTC
Created attachment 892297 [details]
File: backtrace

Comment 2 dwizz.donowin 2014-05-04 15:36:47 UTC
Created attachment 892298 [details]
File: environ

Comment 4 Fedora Update System 2014-07-04 16:31:52 UTC
system-config-printer-1.4.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.5-1.fc20

Comment 5 Fedora Update System 2014-07-05 14:55:46 UTC
Package system-config-printer-1.4.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8100/system-config-printer-1.4.5-1.fc20
then log in and leave karma (feedback).

Comment 6 Jiri Popelka 2014-07-07 07:13:35 UTC
*** Bug 1116507 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-07-10 00:24:02 UTC
system-config-printer-1.4.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.