Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
----------------------------
Guest fail to boot with multiple PCIE downstream bridge behind one upstream bridge.
Version-Release number of selected component (if applicable):
-----------------------------------------------------------------
seabios-1.7.2.2-12.el7.x86_64
qemu-kvm-1.5.3-60.el7.x86_64
How reproducible:
--------------------
100%
Steps to Reproduce:
-----------------------
1. use following script:
#!/bin/sh
cli="$cli /usr/libexec/qemu-kvm -enable-kvm -M q35 -smp 4 -m 3G -usb -device usb-tablet,id=input0 -name RHEL-Server-7.0-64 -drive file=/root/RHEL-Server-6.5-32-virtio.qcow2,if=none,id=hd,format=qcow2,cache=none,werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi0 -device scsi-hd,drive=hd,scsi-id=0,lun=0,id=scsi_image,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0 -spice port=5931,disable-ticketing -vga qxl -monitor stdio -drive file=/root/disk/disk0.qcow2,format=qcow2,if=none,id=disk0 -device virtio-scsi-pci,id=disk0 -device scsi-hd,drive=disk0,scsi-id=0,lun=0 -boot menu=on"
for r in $(seq 1)
do
cli="$cli -device ioh3420,bus=pcie.0,id=root.$r,slot=$r"
cli="$cli -device x3130-upstream,bus=root.$r,id=upstream$r"
echo upstream$r
for k in $(seq 6)
do
cli="$cli -device xio3130-downstream,bus=upstream$r,id=downstream$(((r-1)*15+k)),chassis=$(((r-1)*15+k-1))"
cli="$cli -drive file=/root/disk/disk$(((r-1)*15+k)).qcow2,if=none,id=drive-virtio0-0-$(((r-1)*15+k)),format=qcow2,cache=none -device virtio-blk-pci,scsi=off,drive=drive-virtio0-0-$(((r-1)*15+k)),id=virti0-0-$(((r-1)*15+k)),multifunction=on,bus=downstream$(((r-1)*15+k))"
done
done
echo $i
$cli
2. modify value of "k", when it's 6, guest can boot correctly, when it's 7 and 8, boot menu shows correctly, but guest fails to find the disk, boots from pxe instead, and when it's larger than 8, guest got black screen, bios menu won't show at all.
After roll back to seabios-1.7.2.2-10.el7.x86_64.rpm:
1. still can not find disk when k=8, boot from pxe instead
2. when k=9, guest won't got black screen, situation is the same to k=8. So kind of regression, though it's not too much better before.
(In reply to Shaolong Hu from comment #0)
> Description of problem:
> ----------------------------
> Guest fail to boot with multiple PCIE downstream bridge behind one upstream
> bridge.
>
>
> Version-Release number of selected component (if applicable):
> -----------------------------------------------------------------
> seabios-1.7.2.2-12.el7.x86_64
> qemu-kvm-1.5.3-60.el7.x86_64
> >
>
> 2. modify value of "k", when it's 6, guest can boot correctly, when it's 7
> and 8, boot menu shows correctly, but guest fails to find the disk, boots
> from pxe instead, and when it's larger than 8, guest got black screen, bios
> menu won't show at all.
>
>
>
> After roll back to seabios-1.7.2.2-10.el7.x86_64.rpm:
>
> 1. still can not find disk when k=8, boot from pxe instead
>
> 2. when k=9, guest won't got black screen, situation is the same to k=8. So
> kind of regression, though it's not too much better before.
According to our qe testing result.
With seabios-1.7.2.2-12.el7.x86_64, guest got black screen, bios menu won't show at all.
With seabios-1.7.2.2-10.el7.x86_64.rpm, guest won't got black screen and only won't find disk.
Although both seabios-1.7.2.2-12.el7.x86_64 and seabios-1.7.2.2-10.el7.x86_64 does not works as well but it's kind of regression from qe side. Mark regression first, free to remove the regression keyword with comment if there is wrong.
Too late for 7.1. Deferring to 7.2
Q35 is in tech-preview anyhow.
Limited to 6 ports per switch (not dead otherwise). There are other options ...
It is a bug.
Comment 10Marcel Apfelbaum
2015-12-22 15:26:18 UTC
With current SeaBIOS k can be now 14 and in order to get to 32 do not attach devices that require IO space. Please see BZ 1272938 for further info.
*** This bug has been marked as a duplicate of bug 1272938 ***
Description of problem: ---------------------------- Guest fail to boot with multiple PCIE downstream bridge behind one upstream bridge. Version-Release number of selected component (if applicable): ----------------------------------------------------------------- seabios-1.7.2.2-12.el7.x86_64 qemu-kvm-1.5.3-60.el7.x86_64 How reproducible: -------------------- 100% Steps to Reproduce: ----------------------- 1. use following script: #!/bin/sh cli="$cli /usr/libexec/qemu-kvm -enable-kvm -M q35 -smp 4 -m 3G -usb -device usb-tablet,id=input0 -name RHEL-Server-7.0-64 -drive file=/root/RHEL-Server-6.5-32-virtio.qcow2,if=none,id=hd,format=qcow2,cache=none,werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi0 -device scsi-hd,drive=hd,scsi-id=0,lun=0,id=scsi_image,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0 -spice port=5931,disable-ticketing -vga qxl -monitor stdio -drive file=/root/disk/disk0.qcow2,format=qcow2,if=none,id=disk0 -device virtio-scsi-pci,id=disk0 -device scsi-hd,drive=disk0,scsi-id=0,lun=0 -boot menu=on" for r in $(seq 1) do cli="$cli -device ioh3420,bus=pcie.0,id=root.$r,slot=$r" cli="$cli -device x3130-upstream,bus=root.$r,id=upstream$r" echo upstream$r for k in $(seq 6) do cli="$cli -device xio3130-downstream,bus=upstream$r,id=downstream$(((r-1)*15+k)),chassis=$(((r-1)*15+k-1))" cli="$cli -drive file=/root/disk/disk$(((r-1)*15+k)).qcow2,if=none,id=drive-virtio0-0-$(((r-1)*15+k)),format=qcow2,cache=none -device virtio-blk-pci,scsi=off,drive=drive-virtio0-0-$(((r-1)*15+k)),id=virti0-0-$(((r-1)*15+k)),multifunction=on,bus=downstream$(((r-1)*15+k))" done done echo $i $cli 2. modify value of "k", when it's 6, guest can boot correctly, when it's 7 and 8, boot menu shows correctly, but guest fails to find the disk, boots from pxe instead, and when it's larger than 8, guest got black screen, bios menu won't show at all. After roll back to seabios-1.7.2.2-10.el7.x86_64.rpm: 1. still can not find disk when k=8, boot from pxe instead 2. when k=9, guest won't got black screen, situation is the same to k=8. So kind of regression, though it's not too much better before.