Bug 109423 - Clock sync with ntpd wont update till logout
Summary: Clock sync with ntpd wont update till logout
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-07 18:22 UTC by Jack Aboutboul
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 12:47:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Aboutboul 2003-11-07 18:22:29 UTC
Description of problem:
The clock applet, after a resync with an ntp server done through the
preferences, will not show the new time until after a logout/re-login

Version-Release number of selected component (if applicable):
Clock 2.4.0

How reproducible:
Always

Steps to Reproduce:
1. Update the clock using Network Time Protocol from the preferences
2. Time will not be update right away, so log out immediately
3. Log back in, clock is updated
  
Actual results:


Expected results:


Additional info:

Comment 1 Brad Smith 2004-01-03 13:04:39 UTC
I have the same problem, but I'm not using ntp. 

1. alter the time using redhat-config-date
2. no change to gnome clock applet
3. log out, log back in -- clock is updated

Comment 2 Bart Martens 2004-03-11 20:41:26 UTC
Setting component to gnome-panel.


Comment 3 Mark McLoughlin 2004-10-01 12:47:08 UTC
I couldn't reproduce this issue when you just change the *time*, but
could when you change the timezone. However, the timezone issue is
fixed in rawhide with glibc-2.3.3-60 or later.

Please re-open if you can reproduce this issue with latest rawhide or
FC3 when it comes out. Thanks


Note You need to log in before you can comment on or make changes to this bug.