Bug 1094360 - Disable strict-aliasing optimization for rsh
Summary: Disable strict-aliasing optimization for rsh
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rsh
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1095306
TreeView+ depends on / blocked
 
Reported: 2014-05-05 14:03 UTC by Michal Sekletar
Modified: 2014-06-26 07:57 UTC (History)
4 users (show)

(edit)
Prior to this update, the rsh application was optimized through strict aliasing rules, even though it is not a performance-sensitive application. As a consequence, the GNU compiler collection (GCC) generated warning messages about breaking the strict-aliasing rules, despite correct functionality being the priority for rsh. With this update, strict aliasing has been disabled for rsh. Therefore, GCC now ignores the strict aliasing rules and no longer interrupts rsh processes with warning messages. However, this may also lead to a slight decrease in performance.
Clone Of:
: 1095304 1095306 (view as bug list)
(edit)
Last Closed: 2014-06-26 07:57:21 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0795 normal SHIPPED_LIVE rsh bug fix update 2014-06-26 11:56:57 UTC

Description Michal Sekletar 2014-05-05 14:03:25 UTC
Description of problem:
Warnings about breaking strict aliasing rules in build.log

Version-Release number of selected component (if applicable):
rsh-0.17-60

How reproducible:
always

Steps to Reproduce:
1. Rebuild for RHEL-6.6

Actual results:
rshd.c:453: warning: dereferencing pointer 'second_connect.62' does break strict-aliasing rules

Expected results:
No such warnings

Additional info:
I guess toolchain, i.e. gcc, changed somehow. Let's play this safe and disable optimization. spec only change, add -fno-strict-aliasing to RPM_OPT_FLAGS.

Comment 4 Tomas Dolezal 2014-06-19 09:10:37 UTC
VERIFIED rsh-0.17-64.el6.src.rpm @x86_64

Comment 6 errata-xmlrpc 2014-06-26 07:57:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0795.html


Note You need to log in before you can comment on or make changes to this bug.