Bug 109449 - Gnome setting daemon errors after pannel creation
Gnome setting daemon errors after pannel creation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 16:58 EST by Maxwell Bottiger
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 18:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxwell Bottiger 2003-11-07 16:58:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b)
Gecko/20030516 Mozilla Firebird/0.6

Description of problem:
After having luck with the Fedora test 3 distro on my work computer
and laptop I decided to update my main home computer.  Fedora
installed ok, but after adding some gnome pannels I'm now having lots
of problems.  I would suspect there is something wrong in a gnome
settings file, but I've never edited them so I don't know where to
start really.

I added a second bottom pannel on my second monitor, and placed in it
a clock, workpace switcher, and a window menu.  I also added the gnome
fish to my main pannel.

When I now login, everything but the clock needs to be removed from
the pannel.  Once removed I cannot add them again.  Also, I get the
following error message:
--------------------------------------------------------
There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not
work correctly.

The Settings Daemon restarted too many times.

The last error message was:

Child process did not give an error message, unknown failure occurred

GNOME will still try to restart the Settings Daemon next time you log in.
---------------------------------------------------------

When I log out, and log back in the same error appears, and I am still
unalbe to load any more of the util applets. This is a real pain
because I can't switch to multiple desktops any longer.  Oh, if it
makes a difference, I'm using the sawfish window manager, not metacity.

Version-Release number of selected component (if applicable):
gnome-desktop-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1.log in
2.
3.
    

Additional info:
Comment 1 Kyle R Maxwell 2003-11-12 12:56:00 EST
Same happens to me. Worked fine after upgrading from test3 to core 1
(at that point, just XFree86 and mozilla updates) a few days ago, but
logging in this morning, I get this same error.
Comment 2 Maxwell Bottiger 2003-11-15 10:01:46 EST
Actually, for no apparent reason my error messages disappeared.  I
ended up removing all my pannels but the main one, and every applet I
had on my desktop.  After a reboot or so it suddenly seems ok to add
stuff again.  With the exception of my gnome pager everything seems to
be back to normal.  The pager however, now looses the relative
position of all the windows when I move from one desktop.  Keying in
Alt-F1, etc. seems to work for changing desktops though.  I'm going to
report this to a gnome mailing list and see if I can find some help there.
Comment 3 Kyle R Maxwell 2003-11-15 12:37:57 EST
I've been able to "solve" it by going to a text console and killing
bonobo-activation server (see
http://www.redhat.com/archives/fedora-list/2003-November/msg02748.html).
That's why rebooting seems to fix it. 
Comment 4 Jones Lee 2004-04-04 05:38:33 EDT
Yah, I got same too, very annoying.
Comment 5 Jonathan Blandford 2004-04-22 10:43:20 EDT
Can anyone reproduce this reliably?  If so, can I get them to try a
couple things?
Comment 6 Jeff Needle 2004-08-05 21:06:13 EDT
I can reproduce it 100% of the time on boot - still interested in
debugging it?  If so, my laptop is at your disposal.
Comment 7 Jeff Needle 2004-08-05 21:07:28 EDT
err, make that "on login", not on boot.
Comment 8 Ray Strode [halfline] 2005-05-11 18:12:22 EDT
Fedora Core 1 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Note You need to log in before you can comment on or make changes to this bug.