Bug 109454 - Installer - verify image fits media before issuing "Create boot disk" dialog
Summary: Installer - verify image fits media before issuing "Create boot disk" dialog
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-07 23:08 UTC by Kam Leo
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 21:13:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kam Leo 2003-11-07 23:08:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
After inserting a diskette into the drive it is really annoying to be
informed that the image will not fit.  Why bother with the dialog if
the image will not fit?

How about working a little smarter?  

1. Create an image of the boot disk on the hard drive
2. If image size is less than 1.44 MB display the "Create boot disk"
dialog, else display a message that no  boot disk can be created



Version-Release number of selected component (if applicable):
anaconda-9.2-2

How reproducible:
Always

Steps to Reproduce:
1. Start Fedora Core 1 installation
2. When presented with "Create boot disk" dialog, select "YES"
3. Insert floppy disk into drive and press "OK"
    

Actual Results:  Get "Cannot create boot disk" message.

Expected Results:  Boot disk is created.

Additional info:

Comment 1 Jeremy Katz 2003-11-10 21:13:03 UTC
We check the size of the kernel + initrd and ensure that they're less
than the size of a floppy before prompting you to insert a disk.  You
only hit this case if you're in the edge case that's "close"

Of course, moving forward, boot floppies are going to probably end up
going away completely due to the kernel growing such that it won't fit
on a floppy.


Note You need to log in before you can comment on or make changes to this bug.