Bug 109460 - Crash while upgrading from RH7.3 during "Setting up RPM transaction"
Crash while upgrading from RH7.3 during "Setting up RPM transaction"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 19:31 EST by Steve Lacy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Lacy 2003-11-07 19:31:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I was upgrading my system from RH7.3 to Fedora Core 1, and during the
process that says "Preparing RPM Transaction" the system would shut
itself down and say something like "it is safe to reboot your computer"

The peculiars:

- I was performing the upgrade via NFS, booting from floppy. 
- My / partition is raid, using md
- My /data drive is on SCSI


Version-Release number of selected component (if applicable):
Fedora Core 1 Installer

How reproducible:
Always

Steps to Reproduce:
1.Insert the FedoraCore1 boot floppy and boot the system
2.Select all default options, selecting "Upgrade RedHat 7.3 System"
3.Get to screen saying "Setting up RPM transaction"
4.System reboots
    

Actual Results:  System reboots

Expected Results:  System continues install.

Additional info:
Comment 1 Jeremy Katz 2003-11-10 16:15:10 EST
Does it work if you remove the linuxconf rpm first?
Comment 2 Steve Lacy 2003-11-11 00:47:29 EST
Yes, that worked great.  Thank you very much.  The problem was that I
had to do the following:

# rpm -ev linuxconf-1.25r7-3
error reading information on service linuxconf: No such file or directory
error: execution of %preun scriptlet from linuxconf-1.25r7-3 failed,
exit status 1
# rpm -ev --noscripts linuxconf-1.25r7-3

So, I guess FC1 just couldn't deal with the RPM removal errors.  Weird.

Comment 3 Marcelo Roberto Jimenez 2003-11-28 15:56:40 EST
I have had exactly the same problem upgrading a RH 9.0 that has been 
upgraded continuosly from RH 7.1. Removing linuxconf with --noscripts 
fixed the issue.
Comment 4 Jeremy Katz 2004-10-05 11:28:28 EDT
This should work now in our current codebase.

Note You need to log in before you can comment on or make changes to this bug.