Bug 1094631 - The connection name shows incorrect for remote ipv6 host
Summary: The connection name shows incorrect for remote ipv6 host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 870383 1094628
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-06 07:54 UTC by tingting zheng
Modified: 2015-03-05 10:11 UTC (History)
7 users (show)

Fixed In Version: virt-manager-1.1.0-8.el7
Doc Type: Bug Fix
Doc Text:
Cause: Wrong parsing of IPv6 addresses Consequence: Could not use IPv6 addresses Fix: Fix the parser Result: Now it is possible to connect to an IPV6 address
Clone Of: 1094628
Environment:
Last Closed: 2015-03-05 10:11:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Comment 2 Giuseppe Scrivano 2014-06-05 08:07:15 UTC
fixed upstream by:

commit 0a77093cbc26ace80728382df40328cac6b1347f
Author: Cole Robinson <crobinso>
Date:   Wed Jan 29 11:02:54 2014 -0500

    console: Handle ipv6 addresses (bz 974126)

Comment 3 tingting zheng 2014-11-20 12:16:00 UTC
The bug can still be reproduced on:
virt-manager-1.1.0-7.el7.noarch

So I reopened the bug,would you pls help to check whether the patch is included in virt-manager code.

Comment 4 Giuseppe Scrivano 2014-11-20 12:56:01 UTC
it seems that the patch is not enough.  I've proposed another fix:

https://www.redhat.com/archives/virt-tools-list/2014-November/msg00117.html

Comment 7 CongDong 2014-11-21 09:26:32 UTC
I can reproduce with:
virt-manager-1.1.0-7.el7.noarch

Verify:
virt-manager-1.1.0-8.el7.noarch

Steps:
1. on client host
ifconfig eth0 inet6 add 2004:db8:ac10:fe01::2/64
2. on server 1
ifconfig eth0 inet6 add 2004:db8:ac10:fe01::3/64
3. on server 2
ifconfig eth0 inet6 add 2004:db8:ac10:fe01::3/64

4.  Launch virt-manager and Connect to a server1 ("File ->Add Connection ->Choose Qemu/xen for Hypervisor --> choose 'Remote tunnel over SSH' -->Enter the ipv6 server  address([2004:db8:ac10:fe01::3])  you want to connect.-->Click 'Connect'") and server 2

Result:
connection name of server 1 and 2 on virt-manager are different:
2004:db8:ac10:fe01::3(QEMU)
2004:db8:ac10:fe01::5(QEMU)

Not "2004:db8"


As the result, move to VERIFIED.

Comment 9 errata-xmlrpc 2015-03-05 10:11:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.