Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 109468 - dialog with --menu option returns what appears to be a fatal error from gpm (strncmp/isdigit/option.consolename failed). Sample script snippet included.
dialog with --menu option returns what appears to be a fatal error from gpm (...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 22:04 EST by Scott Kilau
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.20.1-43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 19:31:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Kilau 2003-11-07 22:04:36 EST
Description of problem:

Using:
dialog-0.9b-20031002.1
and:
gpm-1.20.1-38

When using a dialog box with the --menu option, when user selects on 
an option, a bizarre failure from what appears to be the gpm library 
occurs.

Very simple example of problem:
#!/bin/sh

dialog --backtitle "test" --nocancel --title "test"  --menu "test" 19 
10 3 \
        1 "blah 1" \
        2 "blah 2" \
        3 "blah 3" \
        2>/tmp/test.out

A cat of the resulting /tmp/test.out shows:

# more /tmp/test.out 
*** err [lib/liblow.c(267)]:
strncmp/isdigit/option.consolename failed
*** err [lib/liblow.c(376)]:
Oh, oh, it's an error! possibly I die! 
3

Notice that it *does* get the correct value at the very bottom,
but the text above causes problem when parsing the result.

A google scan shows that liblow.c belongs to gpm.


How reproducible:

Occurs every time.

Steps to Reproduce:
1. Try the sample script thats included in description field.
  
Actual results:
*** err [lib/liblow.c(267)]:
strncmp/isdigit/option.consolename failed
*** err [lib/liblow.c(376)]:
Oh, oh, it's an error! possibly I die! 
3


Expected results:
Just "3", no error message.
Comment 1 Harald Hoyer 2003-11-24 05:14:40 EST
cannot reproduce the problem...
$ rpm -q gpm dialog
gpm-1.20.1-38
dialog-0.9b-20031002.1

In which kind of terminal do you run this?
I reassign to gpm then, because of the source of the error message.
Comment 2 Scott Kilau 2003-11-24 17:26:02 EST
I telnet into the Fedora box using SecureCRT,
term type set to "Linux", then run the test script included.

This problem does not occur on RedHat 9.
Comment 3 Steven Shiau 2004-01-19 11:28:03 EST
I comfirmed that I encountered the same problem in FC1, while in RH9
dialog works very well.
Comment 4 jo 2004-02-17 01:04:45 EST
Make this on the shell:

export TERM=eterm

To go Up and Down in mc use ctrl-n and ctrl-p!

Note You need to log in before you can comment on or make changes to this bug.