Bug 109471 - Anaconda does not parse some installer boot commands
Anaconda does not parse some installer boot commands
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-11-08 00:30 EST by Michael Gilbert
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-05 11:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Gilbert 2003-11-08 00:30:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)

Description of problem:
The following installer boot options do not appear to be parsed.

linux noprobe  (video and hardware still appear to be probed)
linux skipddc  (video still appears to be probed)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  place fedora core 1 disc 1 in cd drive
2.  type boot command listed above
3.  watch as the installer probes video and hardware

Expected Results:  video should not be probed.  default svga anaconda
x server should have then started instead of specialized x server.

Additional info:
Comment 1 Jeremy Katz 2003-11-10 16:17:31 EST
Some probing will still occur, but network/scsi modules shouldn't be
autoloaded with noprobe. 
Comment 2 Bart Martens 2003-12-18 15:24:10 EST
I tried "linux expert reboot=bios" at the boot:-prompt. A few steps
later, the installation process stops, with a blue screen, and some
nasty error messages on one of the console screens (alt-f4 I think),
repeating over and over again, every few seconds. I can avoid the
problem by not using installer boot commands, so just hit enter at the
boot:-prompt. I add "reboot=bios" to /etc/grub.conf later.
Comment 3 Bart Martens 2003-12-19 02:51:49 EST
I tried "linux reboot=bios" too., so without "expert". Some of the
naste messages are:

<4>hdc: irq timeout: status=0x80 { Busy }
<4>hdc: irq timeout: error=0x80LastFailedSense 0x08
<4>hdc: ATAPI reset complete

These messages are repeated every few seconds. Some other messages
appear too, but less frequently.

And yes, it's alt-F4.

Comment 4 Jeremy Katz 2004-10-05 11:29:14 EDT
This is basically working as designed.

Note You need to log in before you can comment on or make changes to this bug.