Bug 1094722 - rawtherapee-4.1 is available
Summary: rawtherapee-4.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rawtherapee
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thibault North
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1075267 1100613 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-06 11:06 UTC by Upstream Release Monitoring
Modified: 2014-11-10 06:02 UTC (History)
6 users (show)

Fixed In Version: rawtherapee-4.1-1.fc20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-10 06:02:28 UTC
Type: ---


Attachments (Terms of Use)
specfile patch to 4.1 (3.21 KB, patch)
2014-06-08 16:39 UTC, Matthew Miller
no flags Details | Diff

Description Upstream Release Monitoring 2014-05-06 11:06:28 UTC
Latest upstream release: 4.0.12
Current version/release in Fedora Rawhide: 4.0.11-2.fc20
URL: http://rawtherapee.com/shared/source/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Christopher Meng 2014-05-07 00:37:13 UTC
*** Bug 1075267 has been marked as a duplicate of this bug. ***

Comment 2 Upstream Release Monitoring 2014-05-23 11:41:21 UTC
Latest upstream release: 4.1
Current version/release in Fedora Rawhide: 4.0.11-2.fc20
URL: http://rawtherapee.com/shared/source/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 3 Dariusz Garbowski 2014-05-27 22:06:49 UTC
There are some suggestions to package maintainers made by RawTherapee development team at http://rawtherapee.com/blog/4.1-pre-release-announcement


__quote__
"Package maintainers are please asked to make their builds use a new, empty cache and config folder with a "4.1" suffix by setting the following cmake option:
-DCACHE_NAME_SUFFIX="4.1"
The reasons for this are as follows: [...]"
__end_quote__

Comment 4 Dariusz Garbowski 2014-05-30 21:31:21 UTC
In addition, there's no more PDF manual distributed with RawTherapee. Instead, excellent online documentation is provided at RawPedia,  http://rawpedia.rawtherapee.com/

This fact should make rawtherapee-doc package obsolete, in my opinion.

Comment 5 Matthew Miller 2014-06-08 16:34:40 UTC
(In reply to Dariusz Garbowski from comment #3)
> There are some suggestions to package maintainers made by RawTherapee
> development team at http://rawtherapee.com/blog/4.1-pre-release-announcement
> 
> 
> __quote__
> "Package maintainers are please asked to make their builds use a new, empty
> cache and config folder with a "4.1" suffix by setting the following cmake
> option:
> -DCACHE_NAME_SUFFIX="4.1"
> The reasons for this are as follows: [...]"
> __end_quote__

FWIW, this appears to be handled in the final 4.1 release package already.

Comment 6 Matthew Miller 2014-06-08 16:36:09 UTC
*** Bug 1100613 has been marked as a duplicate of this bug. ***

Comment 7 Matthew Miller 2014-06-08 16:39:25 UTC
Created attachment 903296 [details]
specfile patch to 4.1

This updates the spec file to 4.1.

Comment 8 Radist Morse 2014-06-11 13:44:50 UTC
(In reply to Dariusz Garbowski from comment #3)
> There are some suggestions to package maintainers made by RawTherapee
> development team at http://rawtherapee.com/blog/4.1-pre-release-announcement
> 
> 
> __quote__
> "Package maintainers are please asked to make their builds use a new, empty
> cache and config folder with a "4.1" suffix by setting the following cmake
> option:
> -DCACHE_NAME_SUFFIX="4.1"
> The reasons for this are as follows: [...]"
> __end_quote__

That is only applicable if you move from the previous stable version of 3.1. Since we already have 4.0.11 in our repository, the move will be seamless.

Comment 9 Matthew Miller 2014-06-12 20:57:09 UTC
Updated and built for rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=7040729

Will do F20 if I get a chance over the weekend.

Comment 10 Matthew Miller 2014-06-13 02:33:25 UTC
I made a scratch build for F20 http://koji.fedoraproject.org/koji/taskinfo?taskID=7041714 but I don't have much time to test. It seems to work but I haven't actually put it through the paces. If someone has time to do that, I'll build an update.

Comment 11 Dariusz Garbowski 2014-06-13 07:18:29 UTC
Thanks. I'll try to test it over the weekend.

Comment 12 Dariusz Garbowski 2014-06-15 08:38:15 UTC
Works for me.

Changed number of configuration settings, config files are now in new directory ~/.config/RawTherapee4.1/, processed a few CR2 raw photos, verified output images.

Thanks!

Comment 13 Fedora Update System 2014-06-15 19:49:04 UTC
rawtherapee-4.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rawtherapee-4.1-1.fc20

Comment 14 Fedora Update System 2014-06-16 23:30:24 UTC
Package rawtherapee-4.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rawtherapee-4.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7421/rawtherapee-4.1-1.fc20
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-11-10 06:02:28 UTC
rawtherapee-4.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.