Bug 1094914 - libvirt: script and/or trigger should not directly enable systemd units
libvirt: script and/or trigger should not directly enable systemd units
Status: CLOSED DUPLICATE of bug 850186
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: autoenabled-systemd-units
  Show dependency treegraph
 
Reported: 2014-05-06 13:19 EDT by Andy Lutomirski
Modified: 2014-05-06 13:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-06 13:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy Lutomirski 2014-05-06 13:19:52 EDT
My query script thinks that libvirt has a script or trigger that directly enables a systemd unit using 'systemctl enable'.  It probably should not.  Please update this packages to use the macroized scriptlet (https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd).

If your package has an exception from FESCo permitting it to enable
itself, please make sure that the service in question is listed in the
appropriate preset file.

There is a general exception described here:

https://fedoraproject.org/wiki/Starting_services_by_default

If your package falls under the general exception, then it is possible
that no change is required.  Nevertheless, if you are relying on the
exception, please make sure that your rpm scripts are sensible.  The
exception is:

In addition, any service which does not remain persistent on the system (aka, it "runs once then goes away"), does not listen to incoming connections during initialization, and does not require configuration to be functional may be enabled by default (but is not required to do so). An example of "runs once then goes away" service is iptables.

Given that this issue can affect Fedora 20 users who install your
package as a dependency, this bug should be fixed in Fedora 20 and
Rawhide.
Comment 1 Eric Blake 2014-05-06 13:28:56 EDT
(In reply to Andy Lutomirski from comment #0)
> My query script thinks that libvirt has a script or trigger that directly
> enables a systemd unit using 'systemctl enable'.  It probably should not. 
> Please update this packages to use the macroized scriptlet
> (https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd).

We already use the macroized scriptlet in F18+ and RHEL7+; your script is picking up a false positive where we wrote our spec file to simultaneously work on RHEL6 where the macros did not exist.

I'm closing this as a dup of bug 850186 that drove our initial conversion to the scriptlet macros in the first place.

*** This bug has been marked as a duplicate of bug 850186 ***
Comment 2 Andy Lutomirski 2014-05-06 13:54:17 EDT
You're right.  Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.