Bug 1094944 - Gratuitous vdsm logs causing RHEV-H upgrades to fail
Summary: Gratuitous vdsm logs causing RHEV-H upgrades to fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: ---
: 3.4.0
Assignee: Nobody
QA Contact: Jiri Belka
URL:
Whiteboard: node
Depends On: 1059482
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-06 18:13 UTC by Robert McSwain
Modified: 2019-04-28 09:27 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An update to VDSM changed a path used by libvirt. Consequently, logs were flooded with messages about invalid paths. The virtual machines associated with these logs worked, but migrations from older RHEV-H to newer RHEV-H caused the logs to flood. An update to VDSM adjusts the libvirt XML to match the form the destination is using after a migration from an older version of RHEV-H to a newer version of RHEV-H. Now, logs are no longer flooded with messages about invalid paths.
Clone Of:
Environment:
Last Closed: 2014-06-09 13:30:38 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0504 normal SHIPPED_LIVE vdsm 3.4.0 bug fix and enhancement update 2014-06-09 17:21:35 UTC

Description Robert McSwain 2014-05-06 18:13:56 UTC
Description of problem:
Issue: 
Apr  6 00:00:03 hyper-1-01 vdsm vm.Vm ERROR vmId=`da316c1e-db3e-40cf-a067-90abd16c8903`::Stats function failed: <AdvancedStatsFunction _highWrite at 0x1a848f0>#012Traceback (most recent call last)
:#012  File "/usr/share/vdsm/sampling.py", line 351, in collect#012  File "/usr/share/vdsm/sampling.py", line 226, in __call__#012  File "/usr/share/vdsm/vm.py", line 532, in _highWrite#012  File 
"/usr/share/vdsm/vm.py", line 2320, in extendDrivesIfNeeded#012AttributeError: 'Drive' object has no attribute 'format'

http://lists.ovirt.org/pipermail/users/2013-December/018905.html may be helpful
https://bugzilla.redhat.com/show_bug.cgi?id=1055437 is a duplicate of 
https://bugzilla.redhat.com/show_bug.cgi?id=1059482

Environment:
RHEV 3.3
vdsm-4.13.2-0.13.el6ev.x86_64 on all hosts

From the previously listed BZ:
The problem is because the newer vdsm version configures libvirt to use paths of the form:

/rhev/data-center/mnt/<mountpoint>/<sd uuid>/images/<disk uuid>/<img uuid>
                  ^^^^^^^^^^^^^^^^

whereas the older vdsm used the form

/rhev/data-center/<sp uuid>/<sd uuid>/images/<disk uuid>/<img uuid>
                  ^^^^^^^^^

For VMs started under the new vdsm this is fine, but for VMs migrated from an older hypervisor, the libvirt XML, including the old-style paths is carried along.  That means that the vdsm and libvirt paths are out of sync, causing the error above when vdsm attempts to query libvirt for information about the disk.

Looking into "'Drive' object has no attribute 'format'" on bugzilla returns
Migrating between older and newer RHEV-H images leads to flood "path /rhev/data-center/mnt/blockSD/<UUID>/images/<UUID>/<UUID> not assigned to domain"
https://bugzilla.redhat.com/show_bug.cgi?id=1061621

which points to private solution
3.3.0-3 (no format attribute) VDSM workaround
https://access.redhat.com/site/solutions/727423

which points to the public solution
RHEV 3.3 - VMs get paused due to "no storage space error"
https://access.redhat.com/site/solutions/727433

Version-Release number of selected component (if applicable):
vdsm-4.13.2-0.13.el6ev.x86_64
RHEV-H build of 20140407.0.el6ev 

These versions should not exhibit the issue in https://access.redhat.com/site/solutions/727433

Customer is willing to perform the steps in this solution when they can get the downtime to be able to do so:
https://access.redhat.com/site/solutions/727433

Comment 7 errata-xmlrpc 2014-06-09 13:30:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html


Note You need to log in before you can comment on or make changes to this bug.