Bug 1094948 - Backlight control doesn't work on the Samsung N145P netbook
Summary: Backlight control doesn't work on the Samsung N145P netbook
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-06 18:17 UTC by Vratislav Podzimek
Modified: 2015-01-26 02:31 UTC (History)
11 users (show)

Fixed In Version: kernel-3.18.3-201.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 02:31:01 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmi.log (19.17 KB, text/plain)
2014-12-22 14:16 UTC, Paul Wolfger
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 861573 None None None Never

Description Vratislav Podzimek 2014-05-06 18:17:47 UTC
Description of problem:
Backlight control doesn't work on the Samsung N145P netbook. Hitting the keys make the popup with the with the bar appear and it changes, but the actual brightness doesn't change. The problem seems to be the X server using the /sys/class/backlight/samsung/ interface that doesn't work instead of /sys/class/backlight/intel_backlight/ which works.

Booting with any of:
video.use_native_backlight=1
acpi_backlight=vendor
acpi_osi="!Windows 2012"
acpi_osi="!Windows 2009"

boot options doesn't help. What on the other hand helps is adding the following /etc/X11/xorg.conf.d/80-backlight.conf file:
Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "AccelMethod"     "sna"
  Option      "Backlight"       "intel_backlight"
  Driver      "intel"
  BusID       "PCI:0:2:0"
EndSection


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.21.15-5.fc20.i686
kernel-3.15.0-0.rc3.git4.2.fc21.i686

How reproducible:
100 %

Steps to Reproduce:
1. try to change brightness level with special keyboard keys on the Samsung N145P netbook

Actual results:
no brightness changes

Expected results:
brightness changing

Comment 1 Hans de Goede 2014-05-06 20:02:06 UTC
Looks like this is a regression, can you try with a 3.13 kernel, ie try installing:
http://koji.fedoraproject.org/koji/buildinfo?buildID=512681

If that helps, you can also try a 3.14 kernel, ie:
http://koji.fedoraproject.org/koji/buildinfo?buildID=513888

Thanks,

Hans

Comment 2 Paul Wolfger 2014-12-22 10:27:59 UTC
I have a samsung series 7 notebook (730U3E) using fedora 21 (uefi) and experience the same problem. 

Using ubuntu 14.04.01 backlight control works. Under ubuntu "ls -l /cat/sys/backlight":
lrwxrwxrwx  1 root root 0 Dec 22 09:32 acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
lrwxrwxrwx  1 root root 0 Dec 22 09:32 acpi_video1 -> ../../devices/pci0000:00/0000:00:02.0/backlight/acpi_video1
lrwxrwxrwx  1 root root 0 Dec 22 09:32 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight

changing the brightness effects the values in acpi_video0 and not in intel_backlight

in f21 I only have:
lrwxrwxrwx.  1 root root 0 Dec 22 11:01 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight/
actual_brightness gets updated when using the fn keys, however the brightness does not change

I gladly would provide any needed additional information.
Thanks,
paul

Comment 3 Paul Wolfger 2014-12-22 10:35:16 UTC
ps:
kernel-3.17.6-300.fc21.x86_64
xorg-x11-drv-intel-2.99.916-3.20141117.fc21.x86_64

Comment 4 Hans de Goede 2014-12-22 13:43:38 UTC
Hi,

(In reply to Paul Wolfger from comment #2)
> I have a samsung series 7 notebook (730U3E) using fedora 21 (uefi) and
> experience the same problem. 
> 
> Using ubuntu 14.04.01 backlight control works. Under ubuntu "ls -l
> /cat/sys/backlight":
> lrwxrwxrwx  1 root root 0 Dec 22 09:32 acpi_video0 ->
> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
> lrwxrwxrwx  1 root root 0 Dec 22 09:32 acpi_video1 ->
> ../../devices/pci0000:00/0000:00:02.0/backlight/acpi_video1
> lrwxrwxrwx  1 root root 0 Dec 22 09:32 intel_backlight ->
> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight
> 
> changing the brightness effects the values in acpi_video0 and not in
> intel_backlight
> 
> in f21 I only have:
> lrwxrwxrwx.  1 root root 0 Dec 22 11:01 intel_backlight ->
> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight/
> actual_brightness gets updated when using the fn keys, however the
> brightness does not change

Ok, this sounds like it has a different root-cause then the one of the original reporter, can you try booting with "video.use_native_backlight=0" added to your kernel commandline ? Then you should get back the acpi_video# entries under /sys/class/backlight, and hopefully that will also fix the backlight control.

Also please do:

sudo dmidecode > dmi.log

And attach dmi.log here. Please let me know if the kernel commandline parameter works for you, if it does then I'll add your laptop model to the kernel quirks table containing models which need "video.use_native_backlight=0" so that future kernels will do the right thing automatically.

Regards,

Hans

Comment 5 Paul Wolfger 2014-12-22 14:15:27 UTC
Thank you very much, this kernel parameter does the trick! I can now change the brightness by writing to /sys/class/backlight/acpi_video0/brightness.

However, using the fn keys or the slider in the gnome terminal does only change the values in /sys/class/backlight/intel_backlight/brightness. Do you know how to fix this behaviour?

The dmi.log is attached.

The exact model name:
# cat /sys/class/dmi/id/product_name             
730U3E/740U3E


Best regards,
paul

Comment 6 Paul Wolfger 2014-12-22 14:16:00 UTC
Created attachment 972044 [details]
dmi.log

Comment 7 Hans de Goede 2014-12-22 14:35:56 UTC
Hi,

(In reply to Paul Wolfger from comment #5)
> Thank you very much, this kernel parameter does the trick! I can now change
> the brightness by writing to /sys/class/backlight/acpi_video0/brightness.
> 
> However, using the fn keys or the slider in the gnome terminal does only
> change the values in /sys/class/backlight/intel_backlight/brightness. Do you
> know how to fix this behaviour?

That should not happen, have you perhaps but a custom xorg.conf file somewhere ?

If /sys/class/backlight/acpi_video0 is present then xorg (and via xorg gnome) should prefer it over intel_backlight.

Regards,

Hans

Comment 8 Paul Wolfger 2014-12-22 15:38:42 UTC
No I do not have a custom xorg.conf file. /etc/X11/xorg.conf.d contains a single file, which only defines the keyboard layout:
# cat 00-anaconda-keyboard.conf 
#This file was generated by the Anaconda installer
Section "InputClass"
	Identifier	"anaconda-keyboard"
	MatchIsKeyboard	"on"
	Option	"XkbLayout"	"at"
EndSection%       


Best regards,
paul

Comment 9 Hans de Goede 2015-01-09 12:15:25 UTC
(In reply to Vratislav Podzimek from comment #0)
> Description of problem:
> Backlight control doesn't work on the Samsung N145P netbook. Hitting the
> keys make the popup with the with the bar appear and it changes, but the
> actual brightness doesn't change. The problem seems to be the X server using
> the /sys/class/backlight/samsung/ interface that doesn't work instead of
> /sys/class/backlight/intel_backlight/ which works.
> 
> Booting with any of:
> video.use_native_backlight=1
> acpi_backlight=vendor
> acpi_osi="!Windows 2012"
> acpi_osi="!Windows 2009"
> 
> boot options doesn't help. What on the other hand helps is adding the
> following /etc/X11/xorg.conf.d/80-backlight.conf file:
> Section "Device"
>   Identifier  "Intel Graphics"
>   Driver      "intel"
>   Option      "AccelMethod"     "sna"
>   Option      "Backlight"       "intel_backlight"
>   Driver      "intel"
>   BusID       "PCI:0:2:0"
> EndSection
> 
> 
> Version-Release number of selected component (if applicable):
> xorg-x11-drv-intel-2.21.15-5.fc20.i686
> kernel-3.15.0-0.rc3.git4.2.fc21.i686
> 
> How reproducible:
> 100 %
> 
> Steps to Reproduce:
> 1. try to change brightness level with special keyboard keys on the Samsung
> N145P netbook
> 
> Actual results:
> no brightness changes
> 
> Expected results:
> brightness changing

Hi Vratislav,

I assume that this is still happening ? I've had similar reports from other uses and I'm working on a kernel fix to only export the intel_backlight interface on affected Samsung laptops, to apply this fix to your model to I need to have some of the DMI strings of your model, can you please do:

cat /sys/class/dmi/id/sys_vendor
cat /sys/class/dmi/id/board_name
cat /sys/class/dmi/id/product_name

And copy and paste the output of those 3 commands here ?

Thanks.

Hans

Comment 10 Hans de Goede 2015-01-09 12:17:22 UTC
(In reply to Paul Wolfger from comment #8)
> No I do not have a custom xorg.conf file. /etc/X11/xorg.conf.d contains a

Are you really really sure, have you also looked under /usr/share/X11/xorg.conf.d ? Your latest problem sounds a lot like you've a config file as described in comment 0 of this bug.

What desktop environment are you using ?

Comment 11 Paul Wolfger 2015-01-09 12:32:55 UTC
You were right, under /usr/share/X11/xorg.conf.d I had a config file. I'm sorry, I'm not familiar yet with these new locations.

Nevertheless, thank you very much for your help. Brightness control works now as expected!

Comment 12 Vratislav Podzimek 2015-01-09 12:57:03 UTC
(In reply to Hans de Goede from comment #9)
> (In reply to Vratislav Podzimek from comment #0)
> > Description of problem:
> > Backlight control doesn't work on the Samsung N145P netbook. Hitting the
> > keys make the popup with the with the bar appear and it changes, but the
> > actual brightness doesn't change. The problem seems to be the X server using
> > the /sys/class/backlight/samsung/ interface that doesn't work instead of
> > /sys/class/backlight/intel_backlight/ which works.
> > 
> > Booting with any of:
> > video.use_native_backlight=1
> > acpi_backlight=vendor
> > acpi_osi="!Windows 2012"
> > acpi_osi="!Windows 2009"
> > 
> > boot options doesn't help. What on the other hand helps is adding the
> > following /etc/X11/xorg.conf.d/80-backlight.conf file:
> > Section "Device"
> >   Identifier  "Intel Graphics"
> >   Driver      "intel"
> >   Option      "AccelMethod"     "sna"
> >   Option      "Backlight"       "intel_backlight"
> >   Driver      "intel"
> >   BusID       "PCI:0:2:0"
> > EndSection
> > 
> > 
> > Version-Release number of selected component (if applicable):
> > xorg-x11-drv-intel-2.21.15-5.fc20.i686
> > kernel-3.15.0-0.rc3.git4.2.fc21.i686
> > 
> > How reproducible:
> > 100 %
> > 
> > Steps to Reproduce:
> > 1. try to change brightness level with special keyboard keys on the Samsung
> > N145P netbook
> > 
> > Actual results:
> > no brightness changes
> > 
> > Expected results:
> > brightness changing
> 
> Hi Vratislav,
> 
> I assume that this is still happening ? I've had similar reports from other
> uses and I'm working on a kernel fix to only export the intel_backlight
> interface on affected Samsung laptops, to apply this fix to your model to I
> need to have some of the DMI strings of your model, can you please do:
> 
> cat /sys/class/dmi/id/sys_vendor
> cat /sys/class/dmi/id/board_name
> cat /sys/class/dmi/id/product_name
> 
> And copy and paste the output of those 3 commands here ?
Sure, sorry for the delay, I didn't notice this comment. The issue still happens, without the 80-backlight.conf file brightness controls don't work.

Here are the contents:
/sys/class/dmi/id/sys_vendor:SAMSUNG ELECTRONICS CO., LTD.
/sys/class/dmi/id/board_name:N145P/N250P/N260P          
/sys/class/dmi/id/product_name:N145P/N250P/N260P

Comment 13 Hans de Goede 2015-01-09 15:58:25 UTC
Hi,

I've done a kernel scratch-build, with a fix for both the Samsung N145P and the Samsung series 7 issues discussed in this bug, please give it a try.

Please download the following rpms:
kernel-3.17.8-...rpm
kernel-core-3.17.8-...rpm
kernel-modules-3.17.8-...rpm

For your arch from here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=8571559
(note this is still building atm)

Save them all to the same directory (which should not contain other rpms) and do:

sudo rpm -ivh kernel-*.rpm

From within that directory.

Then:

Vratislav: mv the custom xorg.conf file to somewhere where xorg will not find it; and
Paul: remove the "video.use_native_backlight=0" from the kernel commandline for the new kernel; and
Both:  boot into the new kernel and check if the backlight works as expected.

Thanks & Regards,

Hans

Comment 14 Vratislav Podzimek 2015-01-12 09:37:49 UTC
I can confirm that the kernel build from comment #13 works great on my N145P Samsung netbook. Backlight control works as expected out of the box, no special config nor boot option needed. Thanks!

Comment 15 Hans de Goede 2015-01-12 09:45:12 UTC
(In reply to Vratislav Podzimek from comment #14)
> I can confirm that the kernel build from comment #13 works great on my N145P
> Samsung netbook. Backlight control works as expected out of the box, no
> special config nor boot option needed. Thanks!

Thanks, I've sent the patch upstream and asked Josh Boyer to add the patch fixing this to the official Fedora kernel builds for now.

Comment 16 Josh Boyer 2015-01-12 14:15:15 UTC
Patch added to Fedora git.  Thanks Hans!

Comment 17 Fedora Update System 2015-01-14 13:14:34 UTC
kernel-3.18.2-200.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.2-200.fc21

Comment 18 Fedora Update System 2015-01-14 23:59:52 UTC
Package kernel-3.18.2-200.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.18.2-200.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0724/kernel-3.18.2-200.fc21
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2015-01-19 20:49:14 UTC
kernel-3.18.3-201.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.3-201.fc21

Comment 20 Fedora Update System 2015-01-26 02:31:01 UTC
kernel-3.18.3-201.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.