Bug 1094951 - [GSS](6.4.0) HHH-9261 Multiple detached representations of the same entity cannot be merged using cascade=merge
Summary: [GSS](6.4.0) HHH-9261 Multiple detached representations of the same entity ca...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: DR11
: EAP 6.4.0
Assignee: Gail Badner
QA Contact: Martin Simka
URL:
Whiteboard:
: 1095185 (view as bug list)
Depends On:
Blocks: 1094955 1095192 1121629
TreeView+ depends on / blocked
 
Reported: 2014-05-06 18:29 UTC by Stephen Fikes
Modified: 2019-08-19 12:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
An issue in this release of JBoss EAP 6 could result in an `java.lang.IllegalStateException: An entity copy was already assigned to a different entity` error being encountered. The issue presents during a cascade merge if multiple entity instances with the same identity are detected. As they cannot be automatically merged, the exception is raised. This issue is expected to be resolved in a future release of the product.
Clone Of:
: 1094955 (view as bug list)
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1129983 None None None Never

Description Stephen Fikes 2014-05-06 18:29:00 UTC
Description of problem:
https://hibernate.atlassian.net/browse/HHH-9106

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Brett Meyer 2014-05-07 14:39:35 UTC
*** Bug 1095185 has been marked as a duplicate of this bug. ***

Comment 2 Gail Badner 2014-05-24 01:02:33 UTC
Is this still planned for 6.3.0? 

There are some known issues related to this fix. They should probably be included in release notes. I've also added HHH-9216 for adding documentation about this fix to the upstream documentation. Should that also be included in Hibernate doc for EAP?

I'm not sure if I can finish that by Wednesday. Can it be deferred?  I'm still getting up-to-speed on EAP processes, so I'm unsure of the impact on the one-off. Can someone provide guidance about this?

Comment 5 Gail Badner 2014-06-26 01:11:43 UTC
New JIRA issue for backporting HHH-9106 to 4.2 branch is HHH-9261.

Comment 9 Gail Badner 2014-11-21 02:45:35 UTC
Fixed for 6.4.0.

Comment 10 Kabir Khan 2014-11-21 11:34:35 UTC
Fixed by Hibernate 4.2.16.Final upgrade https://bugzilla.redhat.com/show_bug.cgi?id=1121629

Comment 11 Martin Simka 2014-11-27 12:25:27 UTC
verified on EAP 6.4.0.DR11 / Hibernate 4.2.16


Note You need to log in before you can comment on or make changes to this bug.