Bug 109500 - Network configuration forgets static network route
Network configuration forgets static network route
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks: rcn-profiling
  Show dependency treegraph
 
Reported: 2003-11-08 13:43 EST by clare
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 12:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description clare 2003-11-08 13:43:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
I have my linux box running as a Samba server networked to a windows
XP box. The XP box connects to the net via a USB modem and has
internet connection sharing enabled. The network configurations on my
linux box have the XP box as the gateway and primary DNS, and the
static network route is:
destination network: the IP of the XP box
netmask: 255.255.255.0
gateway: <blank>

On average once a day the internet connection on the linux box does
not work, and when I look at the eth0 settings the static network
route information has disappeared. Once I re-enter it and save it the
'net comes back.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
No idea - as far as I can tell, it just happens.
    

Additional info:
Comment 1 Harald Hoyer 2003-11-24 05:18:55 EST
> The network configurations on my linux box have the XP box as the 
> gateway and primary DNS, and the static network route is:
> destination network: the IP of the XP box
> netmask: 255.255.255.0
> gateway: <blank>

Huh??? if the default gateway is the XP box, why do you have a static
network route?
Comment 2 clare 2003-11-24 05:30:11 EST
Because the network doesn't work if I don't.
Comment 3 Harald Hoyer 2003-11-24 06:10:43 EST
can you please attach the output of:

# redhat-config-network-cmd
Comment 4 clare 2003-11-24 07:44:58 EST
Static routes file eth0 is invalid
DeviceList.Ethernet.eth0.AutoDNS=false
DeviceList.Ethernet.eth0.IP=192.168.0.15
DeviceList.Ethernet.eth0.Type=Ethernet
DeviceList.Ethernet.eth0.OnBoot=true
DeviceList.Ethernet.eth0.Netmask=255.255.255.0
DeviceList.Ethernet.eth0.BootProto=none
DeviceList.Ethernet.eth0.DeviceId=eth0
DeviceList.Ethernet.eth0.Device=eth0
DeviceList.Ethernet.eth0.AllowUser=false
DeviceList.Ethernet.eth0.Gateway=192.168.0.1
HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=ne2k-pci
HardwareList.Ethernet.eth0.Description=RTL-8029(AS)
ProfileList.default.HostsList.1.IP=192.168.0.15
ProfileList.default.HostsList.1.Hostname=Albert
ProfileList.default.HostsList.2.IP=192.168.0.1
ProfileList.default.HostsList.2.Hostname=Dante
ProfileList.default.ActiveDevices.1=eth0
ProfileList.default.DNS.SecondaryDNS=
ProfileList.default.DNS.Domainname=
ProfileList.default.DNS.PrimaryDNS=192.168.0.1
ProfileList.default.DNS.Hostname=Albert
ProfileList.default.DNS.TertiaryDNS=
ProfileList.default.Active=true
ProfileList.default.ProfileName=default
Comment 5 clare 2003-11-24 07:59:48 EST
I've been having a poke around, and I think this might already have
been fixed: it hasn't done it for a few days now, which co-incides
with running up2date for the first time in ages. I'm still getting the
"Static routes file eth0 is invalid" error when I look at my config
(as above) but the route isn't stored and it doesn't affect either
internet connection sharing or file/printer sharing.

Many thanks for your time, I don't want to waste any more of it if
this has been fixed already...

Note You need to log in before you can comment on or make changes to this bug.