Bug 109503 - Can't get internet access through Prism2-based wireless card following upgrade from RH9
Can't get internet access through Prism2-based wireless card following upgrad...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-08 14:55 EST by Need Real Name
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 00:40:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-08 14:55:10 EST
Description of problem:
Installing Fedora Core 1 eliminates wireless access to Internet

Version-Release number of selected component (if applicable):
????

Steps to Reproduce:
1.Install RedHat 9
2.DL and install kernel-wlan-ng-0.2.0-7.i686.rpm, 
kernel-wlan-ng-pcmcia-0.2.0-7.i686.rpm and 
kernel-wlan-ng-modules-rh9.20-0.2.0-7.i686.rpm.  Internet works fine 
with Linksys WPC-11 version 3.  Another system with RH8 and the 
correct RPMs works fine too.  RPMs from http://prism2.unixguru.
raleigh.nc.us/rh9-index.html
3. Upgrade to Fedora - choose no firewall and OS upgraded without 
PCMCIA card in slot.
  
Actual results:
Insert card and no Internet connection

Expected results:
Insert card and get Internet connection.

Additional info:
I also tried installing Fedora from scratch instead of upgrading, 
that did not work either.  Neither did installing Fedora with the 
PCMCIA card in place and using the redhat-network-configuration 
utility.

What was odd is that attempting to remove (rpm -e) the three RPMs did 
not work, but installing them again (on the upgrade, not the fresh 
install of Fedora) gave a message that they were already installed.
Comment 1 Alex Eskin 2003-11-21 20:08:07 EST
I tracked down what may be the same bug. In my case,
typing /etc/rc.d/init.d/pcmcia restart resulted in
failed attempts to load pcmcia_core.o yenta_socket.o and ds.o

The cause is that the prism2 driver (linux-wlan-ng-0.2.1-pre13)
created the file /lib/modules/2.4.22-1.2115.nptl/pcmcia
instead of putting all the stuff into 
/lib/modules/2.4.22-1.2115.nptl/kernel/drivers/pcmcia

This confuses the /etc/rc.d/init.d/pcmcia script into thinking
that I have the old "out-of-kernel" pcmcia instead of the "in-kernel"
pcmcia. In other words, it defines $PC instead of $KD. Then
it tries to load modules with the .o extension, where instead it
should load them without the .o. 

The following patch against /etc/rc.d/init.d/pcmcia fixes
it for me, even though it is probably not the right solution:

--- pcmcia      2003-11-16 13:55:31.000000000 -0600
+++ pcmcia.orig 2003-11-16 13:54:41.000000000 -0600
@@ -104,9 +104,9 @@
            KD=/lib/modules/`uname -r`/kernel/drivers/pcmcia
            if [ -d $PC ] ; then
                echo -n " modules"
-               /sbin/modprobe pcmcia_core $CORE_OPTS
-               /sbin/modprobe $PCIC $PCIC_OPTS
-               /sbin/modprobe ds
+               /sbin/modprobe pcmcia_core.o $CORE_OPTS
+               /sbin/modprobe $PCIC.o $PCIC_OPTS
+               /sbin/modprobe ds.o
            elif [ -d $KD ] ; then
                /sbin/modprobe pcmcia_core
                /sbin/modprobe $PCIC

Note You need to log in before you can comment on or make changes to this bug.